aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-03-18 20:20:26 +0000
committerConor Curran <conor.curran@canonical.com>2010-03-18 20:20:26 +0000
commitb26c97936312634da3fb30e818a76ce2a5a03992 (patch)
tree7bd1abcdb49ab687338e40068ec75a24a199e1ca /tests/Makefile.am
parent69049dd2d6011e9ab96f4f439d00e1de98178449 (diff)
parentda7146ab578829c406c4d3ccde8b89443ba634c9 (diff)
downloadayatana-indicator-sound-b26c97936312634da3fb30e818a76ce2a5a03992.tar.gz
ayatana-indicator-sound-b26c97936312634da3fb30e818a76ce2a5a03992.tar.bz2
ayatana-indicator-sound-b26c97936312634da3fb30e818a76ce2a5a03992.zip
merged in updates from trunk and fixed the tests on the indicator
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5b61b5a..a0562a4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,12 +1,12 @@
-
check_PROGRAMS = \
- test-indicator-sound \
- test-indicator-sound-dbus-client \
- test-indicator-sound-dbus-server
+ test-indicator-sound
+# test-indicator-sound-dbus-client \
+# test-indicator-sound-dbus-server
TESTS = \
test-indicator-sound \
test-pulse-manager
+
DISTCLEANFILES = $(TESTS)
noinst_LTLIBRARIES = libmockpulse.la
@@ -37,7 +37,6 @@ test_indicator_sound_LDADD = \
#########################################
## test-indicator-sound-dbus-client
#########################################
-
test_indicator_sound_dbus_client_SOURCES = \
test-defines.h \
test-indicator-sound-dbus-client.c
@@ -80,7 +79,10 @@ test_indicator_sound_dbus_server_LDADD = \
check_PROGRAMS += test-pulse-manager
test_pulse_manager_SOURCES = \
- test-pulse-manager.c
+ test-pulse-manager.c \
+ $(top_builddir)/src/dbus-menu-manager.c \
+ $(top_builddir)/src/sound-service-dbus.c \
+ $(top_builddir)/src/slider-menu-item.c
test_pulse_manager_CFLAGS = \
$(PULSEAUDIO_CFLAGS) \
@@ -97,7 +99,6 @@ test_pulse_manager_LDADD = \
$(GCONF_LIBS) \
$(APPLET_LIBS)
-
#########################################
## Actual tests
#########################################