aboutsummaryrefslogtreecommitdiff
path: root/tests/dbus-types/CMakeLists.txt
diff options
context:
space:
mode:
authorXavi Garcia Mena <xavi.garcia.mena@canonical.com>2016-01-05 15:08:24 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2016-01-05 15:08:24 +0000
commitde52ce976216ffb25bfb2c3ff3729b6fcf2ec9f4 (patch)
treeb0b4a1fa061be766576e663ac67c63fd2b445563 /tests/dbus-types/CMakeLists.txt
parente1feb61a02a1353b42fcd85ced8e0489c711a451 (diff)
parent6f4f8c2b9caee08499a3a9ee3fd434c2b6a0f3ca (diff)
downloadayatana-indicator-sound-de52ce976216ffb25bfb2c3ff3729b6fcf2ec9f4.tar.gz
ayatana-indicator-sound-de52ce976216ffb25bfb2c3ff3729b6fcf2ec9f4.tar.bz2
ayatana-indicator-sound-de52ce976216ffb25bfb2c3ff3729b6fcf2ec9f4.zip
Adds an action to signal the UI to sync the current volume when we are waiting for the user to confirm or reject the high volume notification. Fixes: #1512798, #1520548
Approved by: PS Jenkins bot, Charles Kerr, Nick Dedekind
Diffstat (limited to 'tests/dbus-types/CMakeLists.txt')
-rw-r--r--tests/dbus-types/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/dbus-types/CMakeLists.txt b/tests/dbus-types/CMakeLists.txt
index cb7f512..a50a5bb 100644
--- a/tests/dbus-types/CMakeLists.txt
+++ b/tests/dbus-types/CMakeLists.txt
@@ -26,7 +26,8 @@ set_source_files_properties(${dbusinterface_properties_xml} PROPERTIES
set(dbusinterface_actions_xml "org.gtk.Actions.xml")
set_source_files_properties(${dbusinterface_actions_xml} PROPERTIES
- CLASSNAME MenusInterface)
+ CLASSNAME MenusInterface
+ INCLUDE "dbus-action-result.h")
set(dbusinterface_notifications_xml "org.freedesktop.Notifications.xml")
set_source_files_properties(${dbusinterface_notifications_xml} PROPERTIES
@@ -44,6 +45,7 @@ add_library(
STATIC
${interface_files}
pulseaudio-volume.cpp
+ dbus-action-result.cpp
)
qt5_use_modules(