aboutsummaryrefslogtreecommitdiff
path: root/tests/dbus-types/CMakeLists.txt
diff options
context:
space:
mode:
authorXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-10-01 15:15:16 +0200
committerXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-10-01 15:15:16 +0200
commit2dba91ca24ce98f866498333c7a39e20d68813f7 (patch)
treea7ccbc1f9eaf06d9cb50d766d7476fe70ffef38f /tests/dbus-types/CMakeLists.txt
parent5d88ce9836c1d32abfd369e650354ed855ec4654 (diff)
downloadayatana-indicator-sound-2dba91ca24ce98f866498333c7a39e20d68813f7.tar.gz
ayatana-indicator-sound-2dba91ca24ce98f866498333c7a39e20d68813f7.tar.bz2
ayatana-indicator-sound-2dba91ca24ce98f866498333c7a39e20d68813f7.zip
added mechanism to wait for the gmenu to change. Added player test for the phone profile
Diffstat (limited to 'tests/dbus-types/CMakeLists.txt')
-rw-r--r--tests/dbus-types/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/dbus-types/CMakeLists.txt b/tests/dbus-types/CMakeLists.txt
index 6346e25..30dff60 100644
--- a/tests/dbus-types/CMakeLists.txt
+++ b/tests/dbus-types/CMakeLists.txt
@@ -24,15 +24,15 @@ set_source_files_properties(${dbusinterface_properties_xml} PROPERTIES
NO_NAMESPACE YES
INCLUDE "dbus-types.h")
-set(dbusinterface_menus_xml "org.gtk.Menus.xml")
-set_source_files_properties(${dbusinterface_menus_xml} PROPERTIES
+set(dbusinterface_actions_xml "org.gtk.Actions.xml")
+set_source_files_properties(${dbusinterface_actions_xml} PROPERTIES
CLASSNAME MenusInterface)
qt5_add_dbus_interface(interface_files ${dbusinterface_streamrestore_xml} stream_restore_interface)
qt5_add_dbus_interface(interface_files ${dbusinterface_properties_xml} dbus_properties_interface)
qt5_add_dbus_interface(interface_files ${dbusinterface_accounts_xml} dbus_accounts_interface)
qt5_add_dbus_interface(interface_files ${dbusinterface_accountssound_xml} dbus_accountssound_interface)
-qt5_add_dbus_interface(interface_files ${dbusinterface_menus_xml} dbus_menus_interface)
+qt5_add_dbus_interface(interface_files ${dbusinterface_actions_xml} dbus_menus_interface)
add_library(
sound-indicator-dbus-interfaces