aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-08 13:09:52 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-08 13:09:52 +0100
commit1a36cae0aa0fc9c4b55efa47a419a3fafdae4923 (patch)
tree428a76cd6f8def241fdd0438d6eac16e2050ec5e /tests/integration/CMakeLists.txt
parent92df05b89070d5409da1b36a9867443d03012f25 (diff)
parentc5eee42075f41041bb838292473b76ca4a89b8cc (diff)
downloadayatana-indicator-sound-1a36cae0aa0fc9c4b55efa47a419a3fafdae4923.tar.gz
ayatana-indicator-sound-1a36cae0aa0fc9c4b55efa47a419a3fafdae4923.tar.bz2
ayatana-indicator-sound-1a36cae0aa0fc9c4b55efa47a419a3fafdae4923.zip
Merge branch 'tari01-pr/fix-qt5-use-modules-warning'
Attributes GH PR #73: https://github.com/AyatanaIndicators/ayatana-indicator-sound/pull/73
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index 164ab8b..97c18b1 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -65,11 +65,11 @@ add_dependencies(
test-home
)
-qt5_use_modules(
+target_link_libraries(
integration-tests
- Core
- DBus
- Test
+ Qt5::Core
+ Qt5::DBus
+ Qt5::Test
)
target_link_options (integration-tests PRIVATE -no-pie)
@@ -120,18 +120,18 @@ add_dependencies(
test-home
)
-qt5_use_modules(
+target_link_libraries(
set-volume
- Core
- DBus
- Test
+ Qt5::Core
+ Qt5::DBus
+ Qt5::Test
)
-qt5_use_modules(
+target_link_libraries(
get-volume
- Core
- DBus
- Test
+ Qt5::Core
+ Qt5::DBus
+ Qt5::Test
)
target_link_libraries(