aboutsummaryrefslogtreecommitdiff
path: root/tests/service-mocks/accounts-mock/CMakeLists.txt
diff options
context:
space:
mode:
authorXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-12-23 14:22:35 +0100
committerXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-12-23 14:22:35 +0100
commitda78e6c75cab23d837cb4768efa3838ddb2286e7 (patch)
tree4f145c3713f350b392820d782179b8d4c72af316 /tests/service-mocks/accounts-mock/CMakeLists.txt
parent478fe08844d29d0383c2c939e504f65ffcd25573 (diff)
downloadayatana-indicator-sound-da78e6c75cab23d837cb4768efa3838ddb2286e7.tar.gz
ayatana-indicator-sound-da78e6c75cab23d837cb4768efa3838ddb2286e7.tar.bz2
ayatana-indicator-sound-da78e6c75cab23d837cb4768efa3838ddb2286e7.zip
restore OSD notifications
Diffstat (limited to 'tests/service-mocks/accounts-mock/CMakeLists.txt')
-rw-r--r--tests/service-mocks/accounts-mock/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/service-mocks/accounts-mock/CMakeLists.txt b/tests/service-mocks/accounts-mock/CMakeLists.txt
new file mode 100644
index 0000000..ad858bd
--- /dev/null
+++ b/tests/service-mocks/accounts-mock/CMakeLists.txt
@@ -0,0 +1,42 @@
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+find_package(Qt5DBus REQUIRED)
+include_directories(${Qt5DBus_INCLUDE_DIRS}
+ "${CMAKE_SOURCE_DIR}/tests/service-mocks")
+
+add_definitions(-DQT_NO_KEYWORDS=1)
+
+set(dbusinterface_sound_xml "com.ubuntu.AccountsService.Sound.Mock.xml")
+set_source_files_properties(${dbusinterface_sound_xml} PROPERTIES
+ CLASSNAME AccountsServiceSoundMockInterface)
+
+qt5_add_dbus_interface(interface_files ${dbusinterface_sound_xml} accountsservice_sound_interface)
+
+qt5_add_dbus_adaptor(adaptor_files
+ com.ubuntu.AccountsService.Sound.Mock.xml
+ AccountsServiceSoundMock.h
+ ubuntu::indicators::testing::AccountsServiceSoundMock
+ AccountsServiceSoundMockAdaptor)
+
+qt5_add_dbus_adaptor(adaptor_files
+ ${CMAKE_SOURCE_DIR}/tests/dbus-types/org.freedesktop.Accounts.xml
+ AccountsMock.h
+ ubuntu::indicators::testing::AccountsMock
+ AccountsMockAdaptor)
+
+add_executable(
+ accounts-service-sound
+ ${interface_files}
+ ${adaptor_files}
+ AccountsServiceSoundMock.cpp
+ AccountsMock.cpp
+ ${CMAKE_SOURCE_DIR}/tests/service-mocks/DBusPropertiesNotifier.cpp
+ main.cpp
+)
+
+qt5_use_modules(
+ accounts-service-sound
+ Core
+ DBus
+)