aboutsummaryrefslogtreecommitdiff
path: root/tests/service-mocks/accounts-mock/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-01-13 13:17:06 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-01-13 13:17:06 +0100
commiteb1f30cb1056e78360f205697dfb489867bec2e5 (patch)
tree3e0f1782cb65a99feec5e787a57b30700b70db27 /tests/service-mocks/accounts-mock/CMakeLists.txt
parent06517ee7ab924755e19962da1eb3ed2882036a97 (diff)
downloadayatana-indicator-sound-eb1f30cb1056e78360f205697dfb489867bec2e5.tar.gz
ayatana-indicator-sound-eb1f30cb1056e78360f205697dfb489867bec2e5.tar.bz2
ayatana-indicator-sound-eb1f30cb1056e78360f205697dfb489867bec2e5.zip
tests/service-mocks/accounts-mock: Re-add com.ubuntu.AccountsService.Sound.Mock.xml and use it for testing this project on Ubuntu.
Diffstat (limited to 'tests/service-mocks/accounts-mock/CMakeLists.txt')
-rw-r--r--tests/service-mocks/accounts-mock/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/service-mocks/accounts-mock/CMakeLists.txt b/tests/service-mocks/accounts-mock/CMakeLists.txt
index ee06146..18f5084 100644
--- a/tests/service-mocks/accounts-mock/CMakeLists.txt
+++ b/tests/service-mocks/accounts-mock/CMakeLists.txt
@@ -5,13 +5,15 @@ find_package(Qt5DBus REQUIRED)
include_directories(${Qt5DBus_INCLUDE_DIRS}
"${CMAKE_SOURCE_DIR}/tests/service-mocks")
+add_definitions(-DQT_NO_KEYWORDS=1)
+
if(EXISTS "/usr/share/accountsservice/interfaces/com.ubuntu.AccountsService.SecurityPrivacy.xml")
add_definitions(-DHAS_UT_ACCTSERVICE_SOUND_SETTINGS)
+ set(dbusinterface_sound_xml "com.ubuntu.AccountsService.Sound.Mock.xml")
+else()
+ set(dbusinterface_sound_xml "org.ayatana.AccountsService.Sound.Mock.xml")
endif()
-add_definitions(-DQT_NO_KEYWORDS=1)
-
-set(dbusinterface_sound_xml "org.ayatana.AccountsService.Sound.Mock.xml")
set_source_files_properties(${dbusinterface_sound_xml} PROPERTIES
CLASSNAME AccountsServiceSoundMockInterface)