aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/correct_ldflags_use.patch13
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/sound_nua.patch13
3 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/correct_ldflags_use.patch b/debian/patches/correct_ldflags_use.patch
new file mode 100644
index 0000000..574ab4b
--- /dev/null
+++ b/debian/patches/correct_ldflags_use.patch
@@ -0,0 +1,13 @@
+=== modified file 'indicator-sound/src/Makefile.am'
+--- indicator-sound/src/Makefile.am 2012-02-14 18:41:28 +0000
++++ indicator-sound/src/Makefile.am 2012-02-14 18:41:43 +0000
+@@ -33,7 +33,7 @@
+ $(COVERAGE_CFLAGS) \
+ -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
+ libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
+-libsoundmenu_la_LDFLAGS =
++libsoundmenu_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
+
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..326ae5e
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+sound_nua.patch
+correct_ldflags_use.patch
+
diff --git a/debian/patches/sound_nua.patch b/debian/patches/sound_nua.patch
new file mode 100644
index 0000000..4b31b61
--- /dev/null
+++ b/debian/patches/sound_nua.patch
@@ -0,0 +1,13 @@
+=== modified file 'src/sound-service-dbus.c'
+--- old/src/sound-service-dbus.c 2011-08-10 16:58:49 +0000
++++ new/src/sound-service-dbus.c 2012-02-09 21:32:58 +0000
+@@ -228,7 +228,7 @@
+ {
+ GError * error = NULL;
+ if (!g_spawn_command_line_async("gnome-volume-control --page=applications", &error) &&
+- !g_spawn_command_line_async("gnome-control-center sound", &error) &&
++ !g_spawn_command_line_async("gnome-control-center sound-nua", &error) &&
+ !g_spawn_command_line_async("xfce4-mixer", &error))
+ {
+ g_warning("Unable to show dialog: %s", error->message);
+