aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/disable_Werror.patch30
-rw-r--r--debian/patches/lazy_init.patch40
-rw-r--r--debian/patches/series2
4 files changed, 82 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2d8b22f..604c0eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+indicator-sound (0.8.0.0-0ubuntu2) precise; urgency=low
+
+ * Add lazy_init.patch: Avoid spawning notification daemon right at startup,
+ instead initialize it lazily when actually doing a notification. Improves
+ boot speed. (LP: #912150)
+ * Add disable_Werror.patch: Build without -Werror, to avoid build failure
+ due to deprecated declarations. (LP: #912160)
+
+ -- Martin Pitt <martin.pitt@ubuntu.com> Thu, 05 Jan 2012 09:29:36 +0100
+
indicator-sound (0.8.0.0-0ubuntu1) precise; urgency=low
* New upstream release.
diff --git a/debian/patches/disable_Werror.patch b/debian/patches/disable_Werror.patch
new file mode 100644
index 0000000..f71eb33
--- /dev/null
+++ b/debian/patches/disable_Werror.patch
@@ -0,0 +1,30 @@
+Description: Build without -Werror, to avoid build failure due to deprecated declarations.
+Author: Martin Pitt <martin.pitt@ubuntu.com>
+Bug: https://launchpad.net/bugs/912160
+
+Index: indicator-sound-0.8.0.0/src/Makefile.in
+===================================================================
+--- indicator-sound-0.8.0.0.orig/src/Makefile.in 2011-12-01 19:33:43.000000000 +0100
++++ indicator-sound-0.8.0.0/src/Makefile.in 2012-01-05 09:43:38.000000000 +0100
+@@ -357,7 +357,7 @@
+ gen-sound-service.xml.c \
+ dbus-shared-names.h
+
+-libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
++libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -DG_LOG_DOMAIN=\"Indicator-Sound\"
+ libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
+ libsoundmenu_la_LDFLAGS = -module -avoid-version
+
+Index: indicator-sound-0.8.0.0/src/Makefile.am
+===================================================================
+--- indicator-sound-0.8.0.0.orig/src/Makefile.am 2011-12-01 15:56:10.000000000 +0100
++++ indicator-sound-0.8.0.0/src/Makefile.am 2012-01-05 09:43:52.670645999 +0100
+@@ -28,7 +28,7 @@
+ gen-sound-service.xml.c \
+ dbus-shared-names.h
+
+-libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
++libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -DG_LOG_DOMAIN=\"Indicator-Sound\"
+ libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
+ libsoundmenu_la_LDFLAGS = -module -avoid-version
+
diff --git a/debian/patches/lazy_init.patch b/debian/patches/lazy_init.patch
new file mode 100644
index 0000000..cc0fe17
--- /dev/null
+++ b/debian/patches/lazy_init.patch
@@ -0,0 +1,40 @@
+Description: Avoid spawning notification daemon right at startup, instead initialize it lazily when actually doing a notification. Improves boot speed.
+Bug: https://launchpad.net/bugs/912150
+Author: Martin Pitt <martin.pitt@ubuntu.com>
+Forwarded: https://code.launchpad.net/~pitti/indicator-sound/lazy-notification-init/+merge/87576
+
+--- a/src/sound-state-manager.c 2011-04-05 03:14:19 +0000
++++ b/src/sound-state-manager.c 2012-01-05 08:46:07 +0000
+@@ -80,8 +80,6 @@
+
+ priv->settings_manager = g_settings_new("com.canonical.indicators.sound");
+
+- sound_state_manager_notification_init (self);
+-
+ sound_state_manager_prepare_state_image_names (self);
+ sound_state_manager_prepare_blocked_animation (self);
+
+@@ -134,6 +132,13 @@
+ static void
+ sound_state_manager_notification_init (SoundStateManager* self)
+ {
++ static gboolean initialized = FALSE;
++
++ /* one-time lazy initialization */
++ if (initialized)
++ return;
++ initialized = TRUE;
++
+ SoundStateManagerPrivate* priv = SOUND_STATE_MANAGER_GET_PRIVATE(self);
+
+ if (!notify_init(PACKAGE_NAME))
+@@ -164,6 +169,8 @@
+ {
+ SoundStateManagerPrivate* priv = SOUND_STATE_MANAGER_GET_PRIVATE(self);
+
++ sound_state_manager_notification_init (self);
++
+ if (priv->notification == NULL ||
+ g_settings_get_boolean (priv->settings_manager, "show-notify-osd-on-scroll") == FALSE){
+ return;
+
diff --git a/debian/patches/series b/debian/patches/series
index e69de29..1dca5f0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+lazy_init.patch
+disable_Werror.patch