aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog25
-rw-r--r--debian/indicator-sound-crashdb.conf6
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/source_indicator-sound.py16
4 files changed, 54 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bc53fe2..d878559 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+indicator-sound (12.10.2+14.04.20140320-0ubuntu1) trusty; urgency=low
+
+ [ Lars Uebernickel ]
+ * Scale volume in notifications when allow-amplified-volume is set
+ (LP: #1293163)
+ * Use audio-volume-mute-blocking-panel instead of *-blocked-panel
+
+ -- Ubuntu daily release <ps-jenkins@lists.canonical.com> Thu, 20 Mar 2014 08:58:30 +0000
+
+indicator-sound (12.10.2+14.04.20140318-0ubuntu1) trusty; urgency=low
+
+ [ Lars Uebernickel ]
+ * Show a red icon in the panel when a sound is playing while mute is
+ on (LP: #1291530)
+
+ -- Ubuntu daily release <ps-jenkins@lists.canonical.com> Tue, 18 Mar 2014 10:01:01 +0000
+
+indicator-sound (12.10.2+14.04.20140313-0ubuntu1) trusty; urgency=low
+
+ [ Lars Uebernickel ]
+ * Don't show player sections on the greeter and lock screen (LP:
+ #1280378)
+
+ -- Ubuntu daily release <ps-jenkins@lists.canonical.com> Thu, 13 Mar 2014 15:33:11 +0000
+
indicator-sound (12.10.2+14.04.20140311.1-0ubuntu1) trusty; urgency=low
[ Lars Uebernickel ]
diff --git a/debian/indicator-sound-crashdb.conf b/debian/indicator-sound-crashdb.conf
new file mode 100644
index 0000000..42e04f7
--- /dev/null
+++ b/debian/indicator-sound-crashdb.conf
@@ -0,0 +1,6 @@
+
+indicator_sound = {
+ 'impl': 'launchpad',
+ 'project': 'indicator-sound',
+ 'bug_pattern_base': None,
+}
diff --git a/debian/rules b/debian/rules
index 9a276dc..6df5436 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,3 +5,10 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
dh $@ --parallel --fail-missing --with translations
+override_dh_install:
+ mkdir -p debian/indicator-sound/usr/share/apport/package-hooks/
+ install -m 644 debian/source_indicator-sound.py debian/indicator-sound/usr/share/apport/package-hooks/
+ mkdir -p debian/indicator-sound/etc/apport/crashdb.conf.d/
+ install -m 644 debian/indicator-sound-crashdb.conf debian/indicator-sound/etc/apport/crashdb.conf.d/
+ dh_install --fail-missing
+
diff --git a/debian/source_indicator-sound.py b/debian/source_indicator-sound.py
new file mode 100644
index 0000000..90e8f4f
--- /dev/null
+++ b/debian/source_indicator-sound.py
@@ -0,0 +1,16 @@
+import os.path
+from apport.hookutils import *
+
+def attach_command_output(report, command_list, key):
+ log = command_output(command_list)
+ if not log or log[:5] == "Error":
+ return
+ report[key] = log
+
+def add_info(report):
+ if not apport.packaging.is_distro_package(report['Package'].split()[0]):
+ report['ThirdParty'] = 'True'
+ report['CrashDB'] = 'indicator_sound'
+
+ if not 'StackTrace' in report:
+ attach_command_output(report, ['gdbus', 'call', '--session', '--dest', 'com.canonical.indicator.sound', '--object-path', '/com/canonical/indicator/sound', '--method', 'org.gtk.Actions.DescribeAll'], 'ActionStates')