aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/sound_nua.patch20
-rw-r--r--debian/patches/sound_ubuntustudio.patch18
-rw-r--r--debian/patches/sound_xubuntu.patch17
-rwxr-xr-xdebian/rules2
6 files changed, 2 insertions, 61 deletions
diff --git a/debian/control b/debian/control
index ee5e310..8abcf59 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,6 @@ XSBC-Original-Maintainer: Conor Curran <conor.curran@canonical.com>
Build-Depends: debhelper (>= 9.0),
dh-autoreconf,
dh-translations,
- quilt,
gnome-common,
autotools-dev,
valac (>= 0.18),
@@ -15,7 +14,7 @@ Build-Depends: debhelper (>= 9.0),
libpulse-mainloop-glib0 (>= 0.9.18),
libgee-dev,
libxml2-dev,
-Standards-Version: 3.9.3
+Standards-Version: 3.9.4
Homepage: https://launchpad.net/indicator-sound
# If you aren't a member of ~indicator-applet-developers but need to upload
# packaging changes, just go ahead. ~indicator-applet-developers will notice
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 92929c8..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,3 +0,0 @@
-sound_nua.patch
-sound_xubuntu.patch
-sound_ubuntustudio.patch
diff --git a/debian/patches/sound_nua.patch b/debian/patches/sound_nua.patch
deleted file mode 100644
index 869ae24..0000000
--- a/debian/patches/sound_nua.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-=== modified file 'src/sound-service-dbus.c'
---- old/src/sound-service-dbus.c 2012-03-16 17:59:34 +0000
-+++ new/src/sound-service-dbus.c 2012-03-19 14:54:30 +0000
-@@ -227,8 +227,14 @@
- gpointer user_data)
- {
- GError * error = NULL;
-+ gchar* cmd;
-+ if (!g_strcmp0 (g_getenv ("XDG_CURRENT_DESKTOP"), "Unity"))
-+ cmd = "gnome-control-center sound-nua";
-+ else
-+ cmd = "gnome-control-center sound";
-+
- if (!g_spawn_command_line_async("gnome-volume-control --page=applications", &error) &&
-- !g_spawn_command_line_async("gnome-control-center sound", &error) &&
-+ !g_spawn_command_line_async(cmd, &error) &&
- !g_spawn_command_line_async("xfce4-mixer", &error))
- {
- g_warning("Unable to show dialog: %s", error->message);
-
diff --git a/debian/patches/sound_ubuntustudio.patch b/debian/patches/sound_ubuntustudio.patch
deleted file mode 100644
index 23d27de..0000000
--- a/debian/patches/sound_ubuntustudio.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: Use pavucontrol on Ubuntu Studio by default
- Xfce4-mixer uses gstreamer0.10-pulseaudio, which doesn't provide full access
- to all audio channels, only to 'Master'.
-Author: Lionel Le Folgoc <mrpouit@ubuntu.com>
-Author: Janne Jokitalo (astraljava) <astraljava@kapsi.fi>
-Last-Update: 2012-04-03
-
---- indicator-sound-0.8.5.0.orig/src/sound-service-dbus.c
-+++ indicator-sound-0.8.5.0/src/sound-service-dbus.c
-@@ -232,6 +232,8 @@ show_sound_settings_dialog (DbusmenuMenu
- cmd = "gnome-control-center sound-nua";
- else if (!g_strcmp0 (g_getenv ("DESKTOP_SESSION"), "xubuntu"))
- cmd = "pavucontrol";
-+ else if (!g_strcmp0 (g_getenv ("DESKTOP_SESSION"), "ubuntustudio"))
-+ cmd = "pavucontrol";
- else
- cmd = "gnome-control-center sound";
-
diff --git a/debian/patches/sound_xubuntu.patch b/debian/patches/sound_xubuntu.patch
deleted file mode 100644
index bbf3db2..0000000
--- a/debian/patches/sound_xubuntu.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Use pavucontrol on Xubuntu by default
- Xfce4-mixer uses gstreamer0.10-pulseaudio, which doesn't provide full access
- to all audio channels, only to 'Master'.
-Author: Lionel Le Folgoc <mrpouit@ubuntu.com>
-Last-Update: 2012-03-21
-
---- indicator-sound-0.8.4.1.orig/src/sound-service-dbus.c
-+++ indicator-sound-0.8.4.1/src/sound-service-dbus.c
-@@ -230,6 +230,8 @@ show_sound_settings_dialog (DbusmenuMenu
- gchar* cmd;
- if (!g_strcmp0 (g_getenv ("XDG_CURRENT_DESKTOP"), "Unity"))
- cmd = "gnome-control-center sound-nua";
-+ else if (!g_strcmp0 (g_getenv ("DESKTOP_SESSION"), "xubuntu"))
-+ cmd = "pavucontrol";
- else
- cmd = "gnome-control-center sound";
-
diff --git a/debian/rules b/debian/rules
index bbe2908..2ce3519 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
- dh $@ --with translations,autoreconf,quilt
+ dh $@ --with translations,autoreconf
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh