aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 09073b9..a703d24 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -104,5 +104,12 @@ target_link_libraries (
${SOUNDSERVICE_LIBRARIES}
${TEST_LIBRARIES}
)
-add_test(accounts-service-user-test accounts-service-user-test)
+# Split tests to work around libaccountservice sucking
+add_test(accounts-service-user-test-basic
+ accounts-service-user-test --gtest_filter=AccountsServiceUserTest.BasicObject
+)
+
+add_test(accounts-service-user-test-player
+ accounts-service-user-test --gtest_filter=AccountsServiceUserTest.SetMediaPlayer
+)