aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..05e1bd0
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,23 @@
+
+check_PROGRAMS = \
+ test-indicator-sound
+
+TESTS =
+DISTCLEANFILES = $(TESTS)
+
+#########################################
+## test-indicator-sound
+#########################################
+test_indicator_sound_SOURCES = \
+ test-indicator-sound.c
+
+test_indicator_sound_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ -Wall -Werror \
+ -I$(srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+test_indicator_sound_LDADD = \
+ $(APPLET_LIBS) \
+ $(INDICATORDIR)/libsoundmenu.la
+