Commit message (Collapse) | Author | Age | Files | Lines | ||
---|---|---|---|---|---|---|
... | ||||||
| | | * | revert previous commit to preserve translation strings (eg, s/USB/Usb/) | Charles Kerr | 2016-01-05 | 2 | -4/+4 | |
| | | | | ||||||
| | | * | typo fix: s/Usb/USB/ in ui strings | charles kerr | 2016-01-01 | 2 | -4/+4 | |
| | | | | ||||||
| | | * | in notifications-test, make the loop test more flexible | charles kerr | 2016-01-01 | 1 | -16/+27 | |
| | | | | ||||||
| | | * | use a custom timer to speed up TriggerWarning's many test combinations | charles kerr | 2015-12-31 | 1 | -2/+28 | |
| | | | | ||||||
| | | * | expand volume warning test to include all trigger requirements | charles kerr | 2015-12-31 | 1 | -31/+74 | |
| | | | | ||||||
| | | * | re-add notifications-test to tests | charles kerr | 2015-12-31 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | in icon picking code, fold redundant cases together | charles kerr | 2015-12-31 | 2 | -185/+54 | |
| | | | | ||||||
| | | * | use the 'unowned' keyword when picking from lists of hardcoded strings | charles kerr | 2015-12-31 | 2 | -16/+16 | |
| | | | | ||||||
| | | * | fix references to unowned strings returned by Environment.get_variable() | charles kerr | 2015-12-31 | 2 | -3/+3 | |
| | | | | ||||||
| | | * | fix references to unowned strings returned by Proplist.gets() | charles kerr | 2015-12-31 | 1 | -4/+4 | |
| | | | | ||||||
| | | * | use predefined VariantTypes instead of reinventing the wheel | charles kerr | 2015-12-31 | 4 | -8/+8 | |
| | | | | ||||||
| | | * | simplify some code in volume-warning and volume-warning-pulse | charles kerr | 2015-12-31 | 2 | -63/+46 | |
| | | | | ||||||
| | | * | copyediting: yet more whitespace | charles kerr | 2015-12-31 | 1 | -25/+25 | |
| | | | | ||||||
| | | * | update POTFILES.in | charles kerr | 2015-12-31 | 1 | -0/+4 | |
| | | | | ||||||
| | | * | in info-warning's icon picking code, fold redundant cases into one. | charles kerr | 2015-12-31 | 1 | -77/+1 | |
| | | | | | | | | | | | | | | | | | | | | | | | | It looks like these switch statements are intended for future expansion, so leaving the basic switching logic intact | |||||
| | | * | copyediting: whitespace | charles kerr | 2015-12-31 | 3 | -22/+24 | |
| | | | | ||||||
| | | * | in Options, make const strings const | charles kerr | 2015-12-31 | 1 | -12/+16 | |
| | | | | ||||||
| | | * | rename VolumeWarning.high_volume_approved as VolumeWarning.approved | charles kerr | 2015-12-31 | 3 | -70/+70 | |
| | | | | | | | | | | | | | | | | | | | | | | | | After being moved into a class named "VolumeWarning", the high_volume_ prefix was redunant. | |||||
| | | * | add new Notifications test for volume-warning requiring headphones | charles kerr | 2015-12-30 | 1 | -0/+59 | |
| | | | | ||||||
| | | * | in mock Notify server, support actions required for volume warnings | charles kerr | 2015-12-30 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | fill out volume-warning-mock's mocking capabilities | charles kerr | 2015-12-30 | 1 | -1/+9 | |
| | | | | ||||||
| | | * | make VolumeControl::active_output easier to mock for tests | charles kerr | 2015-12-30 | 4 | -23/+28 | |
| | | | | ||||||
| | | * | fix and re-enable NotificationsTest::ExtendendVolumeNotification | charles kerr | 2015-12-30 | 1 | -3/+4 | |
| | | | | ||||||
| | | * | when max-volume changes, update volume action state & info notification | charles kerr | 2015-12-30 | 1 | -0/+4 | |
| | | | | ||||||
| | | * | when showing volume notifications, show as a percentage of max-volume | charles kerr | 2015-12-30 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | when showing volume % in notification, clamp to the range of [0%..100%] | charles kerr | 2015-12-30 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | simplify the Options class' properties | charles kerr | 2015-12-30 | 5 | -77/+27 | |
| | | | | ||||||
| | | * | fix rounding regression in info-notification's volume percentage | charles kerr | 2015-12-30 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | remove unused property Notification.visible | charles kerr | 2015-12-29 | 1 | -6/+0 | |
| | | | | ||||||
| | | * | remove ignore_high_volume dupe from volume-warning | charles kerr | 2015-12-29 | 1 | -14/+0 | |
| | | | | ||||||
| | | * | in vol-control-pulse, remove redundant vapi scaffolding | charles kerr | 2015-12-29 | 1 | -4/+1 | |
| | | | | ||||||
| | | * | add docs/comments to vol-warning-pulse | charles kerr | 2015-12-29 | 1 | -9/+16 | |
| | | | | ||||||
| | | * | clean up tracer GLib.message() calls | charles kerr | 2015-12-29 | 4 | -17/+1 | |
| | | | | ||||||
| | | * | remove unnecessary field vol-warning-pulse.multimedia_cvolume | charles kerr | 2015-12-29 | 1 | -7/+2 | |
| | | | | ||||||
| | | * | tidy up vol-warning-pulse's override methods | charles kerr | 2015-12-29 | 1 | -18/+14 | |
| | | | | ||||||
| | | * | generate less pulse traffic on a sink-input-removed event | charles kerr | 2015-12-29 | 1 | -13/+26 | |
| | | | | ||||||
| | | * | fix tyop | charles kerr | 2015-12-29 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | in volume-warning, shorten the Pulse flood damper's timer | charles kerr | 2015-12-29 | 1 | -2/+3 | |
| | | | | | | | | | | | | | | | | | | | | one second is too long in practice; shortening to 500 msec | |||||
| | | * | fix hashset construction error from previous commit | charles kerr | 2015-12-29 | 1 | -1/+1 | |
| | | | | ||||||
| | | * | dampen Pulse floods in vol-warning by requerying no more than once per sec | charles kerr | 2015-12-29 | 2 | -30/+69 | |
| | | | | ||||||
| | | * | silence spurious g_warning | charles kerr | 2015-12-29 | 1 | -4/+5 | |
| | | | | ||||||
| | | * | copyediting: use vala whitespace style in new code | charles kerr | 2015-12-29 | 5 | -119/+84 | |
| | | | | ||||||
| | | * | fix oops in last commit | charles kerr | 2015-12-29 | 1 | -6/+19 | |
| | | | | ||||||
| | | * | in volume-warning-pulse, get/set the sink's volume, not the sink input's | charles kerr | 2015-12-29 | 1 | -25/+54 | |
| | | | | ||||||
| | | * | prefer Source.REMOVE instead of false in timeout funcs | charles kerr | 2015-12-29 | 3 | -6/+5 | |
| | | | | ||||||
| | | * | break volume-warning into an abstract base and concrete pulse-based impl | charles kerr | 2015-12-29 | 6 | -184/+238 | |
| | | | | ||||||
| | | * | copyediting | charles kerr | 2015-12-29 | 1 | -33/+31 | |
| | | | | ||||||
| | | * | bump glib minimum to 2.32 (released Mar 2012) for G_SOURCE_REMOVE | charles kerr | 2015-12-29 | 3 | -1/+4 | |
| | | | | ||||||
| | | * | use G_SOURCE_REMOVE instead of false | charles kerr | 2015-12-29 | 3 | -12/+5 | |
| | | | | ||||||
| | | * | use the InfoNotification class | charles kerr | 2015-12-29 | 3 | -217/+233 | |
| | | | |