diff options
author | Mike Gabriel <mike.gabriel@das-netzwerkteam.de> | 2020-11-09 08:55:58 +0100 |
---|---|---|
committer | Mike Gabriel <mike.gabriel@das-netzwerkteam.de> | 2020-11-09 08:58:16 +0100 |
commit | eefc611960146fbd8ee00253ff9f8efa82917b09 (patch) | |
tree | 035490bc630a8d0c1468e785d0c5d3e97f2b5f61 /setup.py | |
parent | a66c41bede54531e0c94675205593320cc8d2066 (diff) | |
download | ayatana-settings-eefc611960146fbd8ee00253ff9f8efa82917b09.tar.gz ayatana-settings-eefc611960146fbd8ee00253ff9f8efa82917b09.tar.bz2 ayatana-settings-eefc611960146fbd8ee00253ff9f8efa82917b09.zip |
data/: Don't mimick FHS in source tree. Use more commonly used data/ tree structure.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 5 insertions, 3 deletions
@@ -7,7 +7,7 @@ import os, polib, configparser m_lstDataFiles = [] -oFile = open('data/usr/share/applications/{}.desktop'.format(APPNAME), 'r+') +oFile = open('data/applications/{}.desktop'.format(APPNAME), 'r+') oConfigParser = configparser.ConfigParser() oConfigParser.optionxform = str oConfigParser.read_file(oFile) @@ -46,7 +46,7 @@ for strRoot, lstDirnames, lstFilenames in os.walk('po'): if strLocale != APPNAME: - strLocaleDir = 'data/usr/share/locale/' + strLocale + '/LC_MESSAGES/' + strLocaleDir = 'data/locale/' + strLocale + '/LC_MESSAGES/' if not os.path.isdir(strLocaleDir): @@ -63,7 +63,9 @@ for strRoot, lstDirnames, lstFilenames in os.walk('data'): continue strPath = os.path.join(strRoot, strFilename) - m_lstDataFiles.append((os.path.dirname(strPath).lstrip('data'), [strPath])) + m_lstDataFiles.append(("share/{data}".format(data=os.path.dirname(strPath).replace('data/', '')), [strPath])) + +m_lstDataFiles.append(('bin/', ['ayatana-settings'])) setup( name = APPNAME, |