aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-21 10:46:32 -0500
committerTed Gould <ted@gould.cx>2010-09-21 10:46:32 -0500
commit2491cd3e0bc6d6140c28fb5ebcda363299e34e90 (patch)
tree32718c369c09a20cc1613c0585bc5aed429439fb /Makefile.am
parent50aa305c42afacb9b6ba09a3d10961aaebee0626 (diff)
parent1be18c59d8366b80291977e93f97847ba23eca0e (diff)
downloadlibayatana-appindicator-2491cd3e0bc6d6140c28fb5ebcda363299e34e90.tar.gz
libayatana-appindicator-2491cd3e0bc6d6140c28fb5ebcda363299e34e90.tar.bz2
libayatana-appindicator-2491cd3e0bc6d6140c28fb5ebcda363299e34e90.zip
* Upstream Merge
* Fix Mono binding versioning and build (LP: #636132)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ba772b0..98e4a88 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,3 +30,15 @@ dist-hook:
else \
echo Failed to generate ChangeLog: not a branch >&2; \
fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi