aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-03 14:00:39 -0500
committerTed Gould <ted@gould.cx>2010-06-03 14:00:39 -0500
commit614e30aa1dac3cd9fff093cea51055c924c7fb7c (patch)
tree89309ff5df9abb5b8f1dc8225590737301fe69e0 /bindings/mono/Makefile.am
parentd3216b922736af362c23c7b4e52da130907c9c3a (diff)
parent0f7ba97faf10422fd32628636c81563b04d8a6fc (diff)
downloadlibayatana-appindicator-614e30aa1dac3cd9fff093cea51055c924c7fb7c.tar.gz
libayatana-appindicator-614e30aa1dac3cd9fff093cea51055c924c7fb7c.tar.bz2
libayatana-appindicator-614e30aa1dac3cd9fff093cea51055c924c7fb7c.zip
* New upstream release.
* Build GIR and VAPI files * Fixes to documentation and enum construction * Fix distcheck
Diffstat (limited to 'bindings/mono/Makefile.am')
-rw-r--r--bindings/mono/Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/bindings/mono/Makefile.am b/bindings/mono/Makefile.am
index 7e2b0d2..4d2d8b4 100644
--- a/bindings/mono/Makefile.am
+++ b/bindings/mono/Makefile.am
@@ -12,7 +12,7 @@ METADATA = libappindicator-api.metadata
ASSEMBLY_NAME = appindicator-sharp
ASSEMBLY = appindicator-sharp.dll
TARGET = $(ASSEMBLY) $(ASSEMBLY).config
-assemblydir = $(libdir)/appindicator-sharp-0.1
+assemblydir = $(libdir)/cli/appindicator-sharp-0.1
assembly_DATA = $(TARGET)
CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb generated-stamp generated/*.cs $(API) $(MIDDLE_API) $(RAW_API) $(TEST)
DISTCLEANFILES = $(ASSEMBLY).config
@@ -46,21 +46,13 @@ $(MIDDLE_API): $(METADATA) $(RAW_API)
fi
$(API): $(MIDDLE_API) Makefile.am
- sed -e "s|PROP_ID_S|ID|" \
- -e "s|PROP_ID_S|id|" \
- -e "s|PROP_STATUS_S|Status|" \
+ sed -e "s|PROP_ID_S|id|" \
-e "s|PROP_STATUS_S|status|" \
- -e "s|PROP_CATEGORY_S|Category|" \
-e "s|PROP_CATEGORY_S|category|" \
- -e "s|PROP_ICON_NAME_S|IconName|" \
-e "s|PROP_ICON_NAME_S|icon-name|" \
- -e "s|PROP_ATTENTION_ICON_NAME_S|AttentionIconName|" \
-e "s|PROP_ATTENTION_ICON_NAME_S|attention-icon-name|" \
- -e "s|PROP_ICON_THEME_PATH_S|IconThemePath|" \
-e "s|PROP_ICON_THEME_PATH_S|icon-theme-path|" \
- -e "s|PROP_MENU_S|Menu|" \
-e "s|PROP_MENU_S|menu|" \
- -e "s|PROP_CONNECTED_S|Connected|" \
-e "s|PROP_CONNECTED_S|connected|" \
$< > $@