aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-02-24 15:34:16 -0600
committerTed Gould <ted@gould.cx>2011-02-24 15:34:16 -0600
commitce7b22d25a6ee30dc55df5022c72652ad19e406a (patch)
tree30d40ab958ba7e79a8e66e70d42b1616104a21b3 /bindings/mono/Makefile.am
parentabccdd7479fb3a5c1e51e52f91fbe7cada89bfd6 (diff)
parentd21b676e9fe3a9b7f52465cd75d833ce05a6c7a7 (diff)
downloadlibayatana-appindicator-ce7b22d25a6ee30dc55df5022c72652ad19e406a.tar.gz
libayatana-appindicator-ce7b22d25a6ee30dc55df5022c72652ad19e406a.tar.bz2
libayatana-appindicator-ce7b22d25a6ee30dc55df5022c72652ad19e406a.zip
Add the ability to set accessible descriptions for the icon and attention icon.
Diffstat (limited to 'bindings/mono/Makefile.am')
-rw-r--r--bindings/mono/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/bindings/mono/Makefile.am b/bindings/mono/Makefile.am
index dfaa41f..9a899e1 100644
--- a/bindings/mono/Makefile.am
+++ b/bindings/mono/Makefile.am
@@ -85,15 +85,22 @@ $(MIDDLE_API): $(METADATA) $(RAW_API)
$(API): $(MIDDLE_API) Makefile.am
sed -e "s|PROP_ID_S|id|" \
-e "s|PROP_STATUS_S|status|" \
+ -e "s|PROP_CATEGORY_S|Category|" \
-e "s|PROP_CATEGORY_S|category|" \
-e "s|PROP_ICON_NAME_S|icon-name|" \
+ -e "s|PROP_ICON_DESC_S|IconDesc|" \
+ -e "s|PROP_ICON_DESC_S|icon-desc|" \
-e "s|PROP_ATTENTION_ICON_NAME_S|attention-icon-name|" \
+ -e "s|PROP_ATTENTION_ICON_DESC_S|AttentionIconDesc|" \
+ -e "s|PROP_ATTENTION_ICON_DESC_S|attention-icon-desc|" \
-e "s|PROP_ICON_THEME_PATH_S|icon-theme-path|" \
-e "s|PROP_MENU_S|menu|" \
-e "s|PROP_CONNECTED_S|connected|" \
-e "s|PROP_LABEL_S|label|" \
-e "s|PROP_LABEL_GUIDE_S|label-guide|" \
-e "s|PROP_ORDERING_INDEX_S|ordering-index|" \
+ -e "s|PROP_DBUS_MENU_SERVER_S|DbusMenuServer|" \
+ -e "s|PROP_DBUS_MENU_SERVER_S|dbus-menu-server|" \
$< > $@
api_includes = $(GTK_SHARP_CFLAGS)