aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-02-06 14:52:41 -0500
committerKen VanDine <ken.vandine@canonical.com>2012-02-06 14:52:41 -0500
commit2c4628f0647760d314a70d227c88005aa4e89017 (patch)
tree9c83ede4648c8e7506c6f297f7997b8eefa4f036 /bindings/mono/Makefile.am
parent996677f97a04275f47fcc3c540ed7df5333677fe (diff)
parent0ef39fd36500773506b9571cc9475874850a35f1 (diff)
downloadlibayatana-appindicator-2c4628f0647760d314a70d227c88005aa4e89017.tar.gz
libayatana-appindicator-2c4628f0647760d314a70d227c88005aa4e89017.tar.bz2
libayatana-appindicator-2c4628f0647760d314a70d227c88005aa4e89017.zip
* New upstream release.
* Fix include with Dbusmenu 0.5.90 * Fix GTK3 include paths in pkgconfig file (LP: #869373) * Add title property (LP: #923971) * Don't specify pyglib-2.0-python2.6 in LDFLAGS * fix fallback icon of the GtkStatusIcon (LP: #820080) * debian/control: Dbusmneu Dep to 0.5.90 * deibna/*symbols: Updated to add [set|get]_title functions
Diffstat (limited to 'bindings/mono/Makefile.am')
-rw-r--r--bindings/mono/Makefile.am30
1 files changed, 26 insertions, 4 deletions
diff --git a/bindings/mono/Makefile.am b/bindings/mono/Makefile.am
index 9a899e1..f4a59a8 100644
--- a/bindings/mono/Makefile.am
+++ b/bindings/mono/Makefile.am
@@ -3,7 +3,9 @@ SUBDIRS = . examples
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = appindicator-sharp-0.1.pc
+if BUILD_MONO_TEST
TEST = AppIndicator.Test.dll
+endif
API = libappindicator-api.xml
MIDDLE_API = libappindicator-api.middle
@@ -40,16 +42,24 @@ CLEANFILES = \
$(API) \
$(MIDDLE_API) \
$(RAW_API) \
- $(TEST) \
$(DLLPOLICY) \
$(DLLPOLICY1) \
$(WRAPPER_FREE_BINDING) \
$(POLICY).config \
$(POLICY1).config
+if BUILD_MONO_TEST
+CLEANFILES += $(TEST)
+endif
+
DISTCLEANFILES = $(ASSEMBLY).config
+
+if BUILD_MONO_TEST
TEST_SOURCES = TestIndicator.cs
+endif
+
customs = ApplicationIndicator.custom
+
EXTRA_DIST = \
AssemblyInfo.cs \
$(RAW_API) \
@@ -60,13 +70,19 @@ EXTRA_DIST = \
$(ASSEMBLY_NAME).snk \
$(POLICY).config.in \
$(POLICY1).config.in \
- $(customs) \
- $(TEST_SOURCES)
+ $(customs)
+
+if BUILD_MONO_TEST
+EXTRA_DIST += $(TEST_SOURCES)
+endif
GACUTIL_FLAGS=-package $(ASSEMBLY_NAME) -root $(DESTDIR)$(prefix)/lib
references = $(GTK_SHARP_LIBS)
-test_references = $(GTK_SHARP_LIBS) $(NUNIT_LIBS) -r:$(ASSEMBLY)
+
+if BUILD_MONO_TEST
+test_references = $(GTK_SHARP_LIBS) $(NUNIT_LIBS) $(MONO_NUNIT_LIBS) -r:$(ASSEMBLY)
+endif
$(RAW_API): app-indicator.sources.xml $(WRAPPER_FREE_BINDING)
$(GAPI_PARSER) $(srcdir)/app-indicator.sources.xml
@@ -84,12 +100,14 @@ $(MIDDLE_API): $(METADATA) $(RAW_API)
$(API): $(MIDDLE_API) Makefile.am
sed -e "s|PROP_ID_S|id|" \
+ -e "s|PROP_STATUS_S|Status|" \
-e "s|PROP_STATUS_S|status|" \
-e "s|PROP_CATEGORY_S|Category|" \
-e "s|PROP_CATEGORY_S|category|" \
-e "s|PROP_ICON_NAME_S|icon-name|" \
-e "s|PROP_ICON_DESC_S|IconDesc|" \
-e "s|PROP_ICON_DESC_S|icon-desc|" \
+ -e "s|PROP_ATTENTION_ICON_NAME_S|AttentionIconName|" \
-e "s|PROP_ATTENTION_ICON_NAME_S|attention-icon-name|" \
-e "s|PROP_ATTENTION_ICON_DESC_S|AttentionIconDesc|" \
-e "s|PROP_ATTENTION_ICON_DESC_S|attention-icon-desc|" \
@@ -101,6 +119,8 @@ $(API): $(MIDDLE_API) Makefile.am
-e "s|PROP_ORDERING_INDEX_S|ordering-index|" \
-e "s|PROP_DBUS_MENU_SERVER_S|DbusMenuServer|" \
-e "s|PROP_DBUS_MENU_SERVER_S|dbus-menu-server|" \
+ -e "s|PROP_TITLE_S|Title|" \
+ -e "s|PROP_TITLE_S|title|" \
$< > $@
api_includes = $(GTK_SHARP_CFLAGS)
@@ -130,10 +150,12 @@ uninstall-local:
echo "$(GACUTIL) -u $(DLLPOLICY) $(GACUTIL_FLAGS)"; \
$(GACUTIL) -u $(POLICY) $(GACUTIL_FLAGS) || exit 1;
+if BUILD_MONO_TEST
$(TEST): $(ASSEMBLY) $(TEST_SOURCES)
$(CSC) -out:$(TEST) -target:library $(test_references) $(srcdir)/$(TEST_SOURCES)
all: $(TEST)
+endif
$(POLICY).config: $(POLICY).config.in Makefile
sed -e "s|@ASSEMBLY_NAME@|$(ASSEMBLY_NAME)|" \