aboutsummaryrefslogtreecommitdiff
path: root/bindings/python/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-03-09 12:11:25 -0600
committerTed Gould <ted@gould.cx>2012-03-09 12:11:25 -0600
commit6a88fcaecc0d49734e0dae1de1842caceb1b6b95 (patch)
treeee44a43de9e65c499d2ee02cb36bdf245f074923 /bindings/python/Makefile.am
parente602f2a924a06b8627e10c133e1c5531a4d38ffd (diff)
parentb681b75cecff5f916350c6340c137a7c99e7a0c6 (diff)
downloadlibayatana-appindicator-6a88fcaecc0d49734e0dae1de1842caceb1b6b95.tar.gz
libayatana-appindicator-6a88fcaecc0d49734e0dae1de1842caceb1b6b95.tar.bz2
libayatana-appindicator-6a88fcaecc0d49734e0dae1de1842caceb1b6b95.zip
* New upstream release.
* Set name and title in fallback status item (LP: #885080) * Fix build in non-source dir cases (LP: #931764) * Use file names for icons in fallback mode (LP: #875770) * Add since declarations to documentation * Fix test suite to work with libindicator 0.4.93 * Fix the mono binding properties
Diffstat (limited to 'bindings/python/Makefile.am')
-rw-r--r--bindings/python/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
index 7febc11..fe95c02 100644
--- a/bindings/python/Makefile.am
+++ b/bindings/python/Makefile.am
@@ -25,16 +25,15 @@ _appindicator_la_SOURCES = appindicatormodule.c
nodist__appindicator_la_SOURCES = appindicator.c
CLEANFILES = appindicator.c
-EXTRA_DIST = appindicator.override appindicator-arg-types.py $(defs_DATA)
+EXTRA_DIST = appindicator.override.in appindicator-arg-types.py $(defs_DATA)
appindicator.c: $(defs_DATA) appindicator.override
%.c: %.defs
- (cd $(srcdir) \
- && $(PYGTK_CODEGEN) \
+ ($(PYGTK_CODEGEN) \
--register $(PYGTK_DEFSDIR)/gtk-types.defs \
--register $(PYGTK_DEFSDIR)/gdk-types.defs \
- --load-types appindicator-arg-types.py \
+ --load-types $(srcdir)/appindicator-arg-types.py \
--override $*.override \
- --prefix py$* $*.defs) > gen-$*.c \
+ --prefix py$* $(srcdir)/$*.defs) > gen-$*.c \
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c