aboutsummaryrefslogtreecommitdiff
path: root/bindings/python/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-03-09 12:08:33 -0600
committerTed Gould <ted@gould.cx>2012-03-09 12:08:33 -0600
commitb681b75cecff5f916350c6340c137a7c99e7a0c6 (patch)
tree4e15e06c2b7e2884a16f51fb76066a43d28a19ae /bindings/python/Makefile.am
parent7256c1864e94cf172a4c487a5f434e58f6f71666 (diff)
parentf95bf78035fd4e550a67b74e902c0c2ba7df15bc (diff)
downloadlibayatana-appindicator-b681b75cecff5f916350c6340c137a7c99e7a0c6.tar.gz
libayatana-appindicator-b681b75cecff5f916350c6340c137a7c99e7a0c6.tar.bz2
libayatana-appindicator-b681b75cecff5f916350c6340c137a7c99e7a0c6.zip
Import upstream version 0.4.91
Diffstat (limited to 'bindings/python/Makefile.am')
-rw-r--r--bindings/python/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
index 7febc11..fe95c02 100644
--- a/bindings/python/Makefile.am
+++ b/bindings/python/Makefile.am
@@ -25,16 +25,15 @@ _appindicator_la_SOURCES = appindicatormodule.c
nodist__appindicator_la_SOURCES = appindicator.c
CLEANFILES = appindicator.c
-EXTRA_DIST = appindicator.override appindicator-arg-types.py $(defs_DATA)
+EXTRA_DIST = appindicator.override.in appindicator-arg-types.py $(defs_DATA)
appindicator.c: $(defs_DATA) appindicator.override
%.c: %.defs
- (cd $(srcdir) \
- && $(PYGTK_CODEGEN) \
+ ($(PYGTK_CODEGEN) \
--register $(PYGTK_DEFSDIR)/gtk-types.defs \
--register $(PYGTK_DEFSDIR)/gdk-types.defs \
- --load-types appindicator-arg-types.py \
+ --load-types $(srcdir)/appindicator-arg-types.py \
--override $*.override \
- --prefix py$* $*.defs) > gen-$*.c \
+ --prefix py$* $(srcdir)/$*.defs) > gen-$*.c \
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c