aboutsummaryrefslogtreecommitdiff
path: root/bindings/python/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-03-09 19:44:51 +0100
committerSebastien Bacher <seb128@ubuntu.com>2012-03-09 19:44:51 +0100
commit223b045d77554333a297e51b911c60cddff5b1f3 (patch)
tree44fe911799412fc743108904d8045b9ff20c3251 /bindings/python/Makefile.am
parentfe1d218106cb880289463219c2dda162c953d132 (diff)
parentb17679f5966a9c982d788416ada8429f52783c43 (diff)
downloadlibayatana-appindicator-223b045d77554333a297e51b911c60cddff5b1f3.tar.gz
libayatana-appindicator-223b045d77554333a297e51b911c60cddff5b1f3.tar.bz2
libayatana-appindicator-223b045d77554333a297e51b911c60cddff5b1f3.zip
* New upstream release.
* Set name and title in fallback status item (LP: #885080) * Fix build in non-source dir cases (LP: #931764) * Use file names for icons in fallback mode (LP: #875770) * Add since declarations to documentation * Fix test suite to work with libindicator 0.4.93 * Fix the mono binding properties
Diffstat (limited to 'bindings/python/Makefile.am')
-rw-r--r--bindings/python/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
index 7febc11..fe95c02 100644
--- a/bindings/python/Makefile.am
+++ b/bindings/python/Makefile.am
@@ -25,16 +25,15 @@ _appindicator_la_SOURCES = appindicatormodule.c
nodist__appindicator_la_SOURCES = appindicator.c
CLEANFILES = appindicator.c
-EXTRA_DIST = appindicator.override appindicator-arg-types.py $(defs_DATA)
+EXTRA_DIST = appindicator.override.in appindicator-arg-types.py $(defs_DATA)
appindicator.c: $(defs_DATA) appindicator.override
%.c: %.defs
- (cd $(srcdir) \
- && $(PYGTK_CODEGEN) \
+ ($(PYGTK_CODEGEN) \
--register $(PYGTK_DEFSDIR)/gtk-types.defs \
--register $(PYGTK_DEFSDIR)/gdk-types.defs \
- --load-types appindicator-arg-types.py \
+ --load-types $(srcdir)/appindicator-arg-types.py \
--override $*.override \
- --prefix py$* $*.defs) > gen-$*.c \
+ --prefix py$* $(srcdir)/$*.defs) > gen-$*.c \
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c