aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-17 00:14:58 -0600
committerTed Gould <ted@gould.cx>2009-12-17 00:14:58 -0600
commit20a7ac227046fa1e117abfe93ad3c86d923b9d40 (patch)
treec61182ba6c059aa3086267f9b990b740a4b25596 /configure.ac
parent0d66efa5b71d3d4e9e4456ea5a59067b9c923b8e (diff)
parent97f6e62d618747a03ba44486f70a2230af5177fd (diff)
downloadlibayatana-appindicator-20a7ac227046fa1e117abfe93ad3c86d923b9d40.tar.gz
libayatana-appindicator-20a7ac227046fa1e117abfe93ad3c86d923b9d40.tar.bz2
libayatana-appindicator-20a7ac227046fa1e117abfe93ad3c86d923b9d40.zip
* Upstream work
* Python bindings * Mono binding clean up
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca1793a..1ff33d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,6 +132,35 @@ fi
AC_SUBST(DBUSSERVICEDIR)
###########################
+# Python
+###########################
+
+PYGTK_REQUIRED=2.14.0
+PYGOBJECT_REQUIRED=0.22
+
+AM_PATH_PYTHON(2.3.5)
+AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
+ [
+ pygtk-2.0 >= $PYGTK_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ pygobject-2.0 >= $PYGOBJECT_REQUIRED
+ ])
+AC_SUBST(APPINDICATOR_PYTHON_CFLAGS)
+AC_SUBST(APPINDICATOR_PYTHON_LIBS)
+
+AC_MSG_CHECKING(for pygtk defs)
+PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+AC_SUBST(PYGTK_DEFSDIR)
+AC_MSG_RESULT($PYGTK_DEFSDIR)
+
+AC_MSG_CHECKING(for pygtk codegen)
+PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+AC_SUBST(PYGTK_CODEGEN)
+AC_MSG_RESULT($PYGTK_CODEGEN)
+
+###########################
# Files
###########################
@@ -145,6 +174,7 @@ bindings/mono/appindicator-sharp.dll.config
bindings/mono/appindicator-sharp-0.1.pc
bindings/mono/examples/Makefile
bindings/mono/examples/indicator-example
+bindings/python/Makefile
data/Makefile
tests/Makefile
example/Makefile