aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-02-06 14:52:41 -0500
committerKen VanDine <ken.vandine@canonical.com>2012-02-06 14:52:41 -0500
commit2c4628f0647760d314a70d227c88005aa4e89017 (patch)
tree9c83ede4648c8e7506c6f297f7997b8eefa4f036 /configure.ac
parent996677f97a04275f47fcc3c540ed7df5333677fe (diff)
parent0ef39fd36500773506b9571cc9475874850a35f1 (diff)
downloadlibayatana-appindicator-2c4628f0647760d314a70d227c88005aa4e89017.tar.gz
libayatana-appindicator-2c4628f0647760d314a70d227c88005aa4e89017.tar.bz2
libayatana-appindicator-2c4628f0647760d314a70d227c88005aa4e89017.zip
* New upstream release.
* Fix include with Dbusmenu 0.5.90 * Fix GTK3 include paths in pkgconfig file (LP: #869373) * Add title property (LP: #923971) * Don't specify pyglib-2.0-python2.6 in LDFLAGS * fix fallback icon of the GtkStatusIcon (LP: #820080) * debian/control: Dbusmneu Dep to 0.5.90 * deibna/*symbols: Updated to add [set|get]_title functions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 31 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d271627..127307e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_INIT([libappindicator],
- [0.4.1],
+ [0.4.90],
[http://bugs.launchpad.net/libappindicator],
[libappindicator],
[http://launchpad.net/libappindicator])
@@ -45,7 +45,7 @@ GTK3_REQUIRED_VERSION=2.91
GLIB_REQUIRED_VERSION=2.26
GIO_REQUIRED_VERSION=2.26
INDICATOR_REQUIRED_VERSION=0.3.5
-DBUSMENUGTK_REQUIRED_VERSION=0.3.94
+DBUSMENUGTK_REQUIRED_VERSION=0.5.90
DBUS_GLIB_REQUIRED_VERSION=0.82
AC_ARG_WITH([gtk],
@@ -153,7 +153,25 @@ AC_SUBST(GAPI_CODEGEN)
AC_PATH_PROG(GAPI_FIXUP, gapi2-fixup, no)
AC_SUBST(GAPI_FIXUP)
-PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7)
+# Check for nunit
+AC_ARG_ENABLE([mono-test],
+ AC_HELP_STRING([--disable-mono-test], [Disable mono test]),,
+ [enable_mono_test=auto])
+
+if test x"$enable_mono_test" != x"no" ; then
+ PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7,
+ [have_nunit=yes],
+ [PKG_CHECK_MODULES(MONO_NUNIT, mono-nunit,
+ [have_nunit=yes],
+ [have_nunit=no])
+ ])
+ if test x${enable_mono_test} = xyes && test x${have_nunit} = xno; then
+ AC_MSG_ERROR([Mono test configured but nunit not found])
+ fi
+else
+ have_nunit=no
+fi
+AM_CONDITIONAL(BUILD_MONO_TEST, test x${have_nunit} = xyes)
###########################
# Check to see if we're local
@@ -189,6 +207,14 @@ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
AC_SUBST(PYGTK_CODEGEN)
AC_MSG_RESULT($PYGTK_CODEGEN)
+#########################
+# Check if build tests
+#########################
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [Disable tests]),,
+ [enable_tests=yes])
+AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
+
###########################
# Files
###########################
@@ -226,4 +252,6 @@ Libappindicator Configuration:
Prefix: $prefix
GTK+ Version: $with_gtk
+ Tests: $enable_tests
+ Mono tests: $have_nunit
])