aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2011-02-03 16:22:06 +0100
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2011-02-03 16:22:06 +0100
commit7f49d7c2602ccb2ef01c64067e2abcc6b5715200 (patch)
tree48fe2d080655bb443e07795c26e7791eed034a72 /configure.ac
parent19c543fd42571ef3e011db21a6d93e93d7da4483 (diff)
downloadlibayatana-appindicator-7f49d7c2602ccb2ef01c64067e2abcc6b5715200.tar.gz
libayatana-appindicator-7f49d7c2602ccb2ef01c64067e2abcc6b5715200.tar.bz2
libayatana-appindicator-7f49d7c2602ccb2ef01c64067e2abcc6b5715200.zip
Adding vala bindings and example
Adding proper support for vala bindings, fixing the include path Now they are built in the bindings subfolder and they include a *.deps file. and I've also added a small example.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f78786..f689003 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,13 @@ AM_CONDITIONAL(INTROSPECTION_TEN, [test "x$introspection_ten" = "xyes"])
AC_PATH_PROG([VALA_API_GEN], [vapigen])
###########################
+# Vala Compiler support
+###########################
+
+AM_PROG_VALAC([0.11.0])
+AM_CONDITIONAL(HAVE_VALAC, [test "x$VALAC" != "x"])
+
+###########################
# Check for Mono support
###########################
@@ -205,6 +212,8 @@ bindings/mono/appindicator-sharp-0.1.pc
bindings/mono/examples/Makefile
bindings/mono/examples/indicator-example
bindings/python/Makefile
+bindings/vala/Makefile
+bindings/vala/examples/Makefile
tests/Makefile
example/Makefile
docs/Makefile