aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-03 21:43:40 -0600
committerTed Gould <ted@gould.cx>2010-12-03 21:43:40 -0600
commitfbf708eb94946bf976ea3902f00d4a4376c760da (patch)
treeaba8d989bb0ac824893f7e07f2801df868a0f673 /configure.ac
parent6145439d03bae606b1376795b10e934dfe76293f (diff)
parentc2e08e008bd9ea4f43a15390e6e4116cc714521a (diff)
downloadlibayatana-appindicator-fbf708eb94946bf976ea3902f00d4a4376c760da.tar.gz
libayatana-appindicator-fbf708eb94946bf976ea3902f00d4a4376c760da.tar.bz2
libayatana-appindicator-fbf708eb94946bf976ea3902f00d4a4376c760da.zip
Adding a convience function for building the items from a desktop file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4409c42..9c3f61f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,14 @@ AS_IF([test "x$with_gtk" = x3],
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
+PKG_CHECK_MODULES(LIBRARY, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ indicator >= $INDICATOR_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+
+AC_SUBST(LIBRARY_CFLAGS)
+AC_SUBST(LIBRARY_LIBS)
+
###########################
# GObject Introspection
###########################