aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGyörgy Balló <ballogy@freestart.hu>2011-11-22 08:36:34 +0100
committerGyörgy Balló <ballogy@freestart.hu>2011-11-22 08:36:34 +0100
commit077275b799305cc99a5c20a5fbe43cc2121ce618 (patch)
tree5ef3a0006e40e26c965872f61d7e7edc3d4c0d45 /configure.ac
parentbc49dd8e9acfd1069e99999fd573609a404de869 (diff)
downloadlibayatana-appindicator-077275b799305cc99a5c20a5fbe43cc2121ce618.tar.gz
libayatana-appindicator-077275b799305cc99a5c20a5fbe43cc2121ce618.tar.bz2
libayatana-appindicator-077275b799305cc99a5c20a5fbe43cc2121ce618.zip
Make building tests optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d271627..b05f967 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,6 +189,14 @@ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
AC_SUBST(PYGTK_CODEGEN)
AC_MSG_RESULT($PYGTK_CODEGEN)
+#########################
+# Check if build tests
+#########################
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [Disable tests]),,
+ [enable_tests=yes])
+AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
+
###########################
# Files
###########################
@@ -226,4 +234,5 @@ Libappindicator Configuration:
Prefix: $prefix
GTK+ Version: $with_gtk
+ Tests: $enable_tests
])