aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-27 16:54:01 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-27 16:54:01 -0500
commit6f293994f8f9c260401fd76a189c7461b1b5f994 (patch)
treefe3924ca8a6d3bf8b656d2b4d87800d7b1fa578c /configure.ac
parent328e55e2a006ca560deaf921b4017f07c4ef41f6 (diff)
downloadlibayatana-appindicator-6f293994f8f9c260401fd76a189c7461b1b5f994.tar.gz
libayatana-appindicator-6f293994f8f9c260401fd76a189c7461b1b5f994.tar.bz2
libayatana-appindicator-6f293994f8f9c260401fd76a189c7461b1b5f994.zip
Added coverage tooling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c067e9..f38947d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,6 +216,19 @@ AC_ARG_ENABLE([tests],
AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -256,4 +269,5 @@ Libappindicator Configuration:
GTK+ Version: $with_gtk
Tests: $enable_tests
Mono tests: $have_nunit
+ gcov: $use_gcov
])