aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGyörgy Balló <ballogy@freestart.hu>2011-11-23 03:47:46 +0100
committerGyörgy Balló <ballogy@freestart.hu>2011-11-23 03:47:46 +0100
commitce8b8824e6c8b690e1f8dbd66779ecad8e03334b (patch)
treeae404dc2a663049bb8f9d488868d9f4757c0017a /configure.ac
parent077275b799305cc99a5c20a5fbe43cc2121ce618 (diff)
downloadlibayatana-appindicator-ce8b8824e6c8b690e1f8dbd66779ecad8e03334b.tar.gz
libayatana-appindicator-ce8b8824e6c8b690e1f8dbd66779ecad8e03334b.tar.bz2
libayatana-appindicator-ce8b8824e6c8b690e1f8dbd66779ecad8e03334b.zip
Make building mono tests optional. Check for mono-nunit if nunit is not available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b05f967..fe2d754 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,7 +153,25 @@ AC_SUBST(GAPI_CODEGEN)
AC_PATH_PROG(GAPI_FIXUP, gapi2-fixup, no)
AC_SUBST(GAPI_FIXUP)
-PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7)
+# Check for nunit
+AC_ARG_ENABLE([mono-test],
+ AC_HELP_STRING([--disable-mono-test], [Disable mono test]),,
+ [enable_mono_test=auto])
+
+if test x"$enable_mono_test" != x"no" ; then
+ PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7,
+ [have_nunit=yes],
+ [PKG_CHECK_MODULES(MONO_NUNIT, mono-nunit,
+ [have_nunit=yes],
+ [have_nunit=no])
+ ])
+ if test x${enable_mono_test} = xyes && test x${have_nunit} = xno; then
+ AC_MSG_ERROR([Mono test configured but nunit not found])
+ fi
+else
+ have_nunit=no
+fi
+AM_CONDITIONAL(BUILD_MONO_TEST, test x${have_nunit} = xyes)
###########################
# Check to see if we're local
@@ -235,4 +253,5 @@ Libappindicator Configuration:
Prefix: $prefix
GTK+ Version: $with_gtk
Tests: $enable_tests
+ Mono tests: $have_nunit
])