aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/disconnect-from-theme.patch
diff options
context:
space:
mode:
authorMichael Terry <mike@mterry.name>2011-02-28 08:58:38 -0500
committerMichael Terry <mike@mterry.name>2011-02-28 08:58:38 -0500
commit49874d38804ea6cc47d3a241600e4f0a12f9fc1a (patch)
treebeb80910176c797b9d5435688670654b9cd48156 /debian/patches/disconnect-from-theme.patch
parent5f97e91d0017b93369d3ddc7e7354a8f285bf336 (diff)
downloadlibayatana-appindicator-49874d38804ea6cc47d3a241600e4f0a12f9fc1a.tar.gz
libayatana-appindicator-49874d38804ea6cc47d3a241600e4f0a12f9fc1a.tar.bz2
libayatana-appindicator-49874d38804ea6cc47d3a241600e4f0a12f9fc1a.zip
* debian/control, debian/rules:0.2.96-0ubuntu2
- Add quilt * debian/patches/disconnect-from-theme.patch: - Fix crash when switching themes by disconnecting a signal from the theme on dispose. LP: #708188
Diffstat (limited to 'debian/patches/disconnect-from-theme.patch')
-rw-r--r--debian/patches/disconnect-from-theme.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/patches/disconnect-from-theme.patch b/debian/patches/disconnect-from-theme.patch
new file mode 100644
index 0000000..a60502c
--- /dev/null
+++ b/debian/patches/disconnect-from-theme.patch
@@ -0,0 +1,14 @@
+=== modified file 'src/app-indicator.c'
+Index: libappindicator.ubu/src/app-indicator.c
+===================================================================
+--- libappindicator.ubu.orig/src/app-indicator.c 2011-02-28 08:35:28.963390000 -0500
++++ libappindicator.ubu/src/app-indicator.c 2011-02-28 08:46:54.147065973 -0500
+@@ -667,6 +667,8 @@
+ priv->connection = NULL;
+ }
+
++ g_signal_handlers_disconnect_by_func(gtk_icon_theme_get_default(), G_CALLBACK(theme_changed_cb), self);
++
+ G_OBJECT_CLASS (app_indicator_parent_class)->dispose (object);
+ return;
+ }