aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-17 00:20:25 -0600
committerTed Gould <ted@gould.cx>2009-12-17 00:20:25 -0600
commit5aed77c03c6b06766efb1cfd1b1efc1a322f29f1 (patch)
tree331f532e4b8ced7eaac1a683c869b9a13a864f52 /debian/rules
parent20a7ac227046fa1e117abfe93ad3c86d923b9d40 (diff)
parent394f01517e11b929ae249e002cae00731e1fe2ee (diff)
downloadlibayatana-appindicator-5aed77c03c6b06766efb1cfd1b1efc1a322f29f1.tar.gz
libayatana-appindicator-5aed77c03c6b06766efb1cfd1b1efc1a322f29f1.tar.bz2
libayatana-appindicator-5aed77c03c6b06766efb1cfd1b1efc1a322f29f1.zip
* Added mono bindings
* debian/rules - don't use gnome.mk, specify all the targets to build python bindings for each supported python version * Adding in Python bindings. * debian/control, debian/python-appindicator.install: Building a binary package for the python bindings. * debian/control: Adding python building build deps * debian/control - make libappindicator0 recommend indicator-application * debian/rules: - removed the disable-scrollkeeper configure arg - don't include .la and .a files * debian/patches/clean_up_docs.patch - removed, merged upstream * debian/control: - removed Build-Depend for scrollkeeper - libappindicator-dev needs to depend on libdbusmenu-glib-dev - bump standards version to 3.8.3 - libappindicator-doc doesn't need to depend on libappindicator0 - set libappindicator-doc arch all - make libappindicator-dev depend on libappindicator0 * debian/copyright - Include the proper licenses (LGPL-2.1 and LGPL-3)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules71
1 files changed, 69 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 30ee9cc..7936902 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,76 @@
#!/usr/bin/make -f
+DEB_PYTHON_SYSTEM=pycentral
+PY_VERSIONS = $(shell pyversions --requested debian/control)
+export MONO_SHARED_DIR=$(CURDIR)
+
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
+include /usr/share/cdbs/1/class/autotools-vars.mk
+include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
DEB_CONFIGURE_EXTRA_FLAGS += --enable-gtk-doc
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+API_VERSION = 0.1
+
+configure-stamp-%:
+ mkdir build-$*
+ cd build-$* && PYTHON=`which $*` \
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) --srcdir=..
+ touch $@
+
+configure/python-appindicator:: $(addprefix configure-stamp-, $(PY_VERSIONS))
+
+build-stamp-%:
+ make -C build-$*/bindings/python
+ touch $@
+
+build/python-appindicator:: $(addprefix build-stamp-, $(PY_VERSIONS))
+
+install-stamp-%:
+ make -C build-$*/bindings/python install DESTDIR=$(CURDIR)/debian/tmp
+ touch $@
+
+install/python-appindicator:: $(addprefix install-stamp-, $(PY_VERSIONS))
+
+binary-install/python-appindicator::
+ dh_pycentral
+
+configure-stamp:
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)
+ touch $@
+
+configure/indicator-application:: configure-stamp
+
+build-stamp:
+ make
+ touch $@
+
+build/indicator-application:: build-stamp
+
+install-stamp:
+ make install DESTDIR=$(CURDIR)/debian/tmp
+ touch $@
+
+install/indicator-application:: install-stamp
+
+binary-post-install/indicator-application::
+ find debian/indicator-application/usr/lib -name \*.la -exec rm {} \;
+ find debian/indicator-application/usr/lib -name \*.a -exec rm {} \;
+
+binary/libappindicator0-cil:: binary-arch
+binary-arch:
+ dh_clifixperms -i
+ dh_installdeb -i
+ dh_makeclilibs -m $(API_VERSION)
+ dh_clideps -i -d
+
+
+common-binary-predeb-arch:: list-missing
+
+clean::
+ -rm -rf $(addprefix build-, $(PY_VERSIONS))
+ -rm -rf $(addprefix configure-stamp-, $(PY_VERSIONS))
+ -rm -rf $(addprefix build-stamp-, $(PY_VERSIONS))
+ -rm -rf $(addprefix install-stamp-, $(PY_VERSIONS))
+ rm -rf $(MONO_SHARED_DIR)/.wapi