aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-03-03 17:20:11 -0500
committerKen VanDine <ken.vandine@canonical.com>2011-03-03 17:20:11 -0500
commit007331a4fa96261065624aa8c369219f80ffbd74 (patch)
treea4f826b2ac0b4a9aadbc465548d007247e621659 /debian
parentfe59d572cdec7291b27bee9135e56cb7a7ad6a4f (diff)
parentbe0a541c8a33f32bfae86fe8e03ebb0245cf6602 (diff)
downloadlibayatana-appindicator-007331a4fa96261065624aa8c369219f80ffbd74.tar.gz
libayatana-appindicator-007331a4fa96261065624aa8c369219f80ffbd74.tar.bz2
libayatana-appindicator-007331a4fa96261065624aa8c369219f80ffbd74.zip
releasing version 0.2.97-0ubuntu10.2.97-0ubuntu1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/patches/disconnect-from-theme.patch14
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/update-defs.patch169
4 files changed, 12 insertions, 185 deletions
diff --git a/debian/changelog b/debian/changelog
index 72c3b15..0f5b4b4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+libappindicator (0.2.97-0ubuntu1) natty; urgency=low
+
+ * New upstream release.
+ * Set includedir to the location of the headers provided by
+ libappindicator-dev (LP: #721562)
+ * Fix crash when importing appindicator from Python (LP: #724917).
+ * Fix crash when switching themes by disconnecting a signal from
+ the theme on dispose. (LP: #708188)
+ * debian/patches: Removed, all upstream
+
+ -- Ted Gould <ted@ubuntu.com> Thu, 03 Mar 2011 13:42:10 -0600
+
libappindicator (0.2.96-0ubuntu4) natty; urgency=low
* src/appindicator3-0.1.pc.in
diff --git a/debian/patches/disconnect-from-theme.patch b/debian/patches/disconnect-from-theme.patch
deleted file mode 100644
index a60502c..0000000
--- a/debian/patches/disconnect-from-theme.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-=== modified file 'src/app-indicator.c'
-Index: libappindicator.ubu/src/app-indicator.c
-===================================================================
---- libappindicator.ubu.orig/src/app-indicator.c 2011-02-28 08:35:28.963390000 -0500
-+++ libappindicator.ubu/src/app-indicator.c 2011-02-28 08:46:54.147065973 -0500
-@@ -667,6 +667,8 @@
- priv->connection = NULL;
- }
-
-+ g_signal_handlers_disconnect_by_func(gtk_icon_theme_get_default(), G_CALLBACK(theme_changed_cb), self);
-+
- G_OBJECT_CLASS (app_indicator_parent_class)->dispose (object);
- return;
- }
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index be957fd..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,2 +0,0 @@
-disconnect-from-theme.patch
-update-defs.patch
diff --git a/debian/patches/update-defs.patch b/debian/patches/update-defs.patch
deleted file mode 100644
index 56bbba2..0000000
--- a/debian/patches/update-defs.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-Index: ubuntu/bindings/python/appindicator.defs
-===================================================================
---- ubuntu.orig/bindings/python/appindicator.defs 2011-02-28 22:32:45.853399929 +0600
-+++ ubuntu/bindings/python/appindicator.defs 2011-02-28 22:33:12.205528749 +0600
-@@ -33,7 +33,6 @@
- )
- )
-
--
- ;; From app-indicator.h
-
- (define-function app_indicator_get_type
-@@ -62,57 +61,50 @@
- )
- )
-
--(define-method set_label
-+(define-method set_attention_icon
- (of-object "AppIndicator")
-- (c-name "app_indicator_set_label")
-+ (c-name "app_indicator_set_attention_icon_full")
- (return-type "none")
- (parameters
-- '("const-gchar*" "label" (null-ok))
-- '("const-gchar*" "guide" (null-ok) (default "NULL"))
-+ '("const-gchar*" "icon_name")
-+ '("const-gchar*" "icon_desc" (null-ok) (default "NULL"))
- )
- )
-
--(define-method set_accessible_desc
-+(define-method set_menu
- (of-object "AppIndicator")
-- (c-name "app_indicator_set_accessible_desc")
-+ (c-name "app_indicator_set_menu")
- (return-type "none")
- (parameters
-- '("const-gchar*" "accessible_desc" (null-ok))
-- )
--)
--
--(define-method set_ordering_index
-- (of-object "AppIndicator")
-- (c-name "app_indicator_set_ordering_index")
-- (parameters
-- '("guint32" "ordering_index")
-+ '("GtkMenu*" "menu")
- )
- )
-
--(define-method set_attention_icon
-+(define-method set_icon
- (of-object "AppIndicator")
-- (c-name "app_indicator_set_attention_icon")
-+ (c-name "app_indicator_set_icon_full")
- (return-type "none")
- (parameters
- '("const-gchar*" "icon_name")
-+ '("const-gchar*" "icon_desc" (null-ok) (default "NULL"))
- )
- )
-
--(define-method set_menu
-+(define-method set_label
- (of-object "AppIndicator")
-- (c-name "app_indicator_set_menu")
-+ (c-name "app_indicator_set_label")
- (return-type "none")
- (parameters
-- '("GtkMenu*" "menu")
-+ '("const-gchar*" "label" (null-ok))
-+ '("const-gchar*" "guide" (null-ok) (default "NULL"))
- )
- )
-
--(define-method set_icon
-+(define-method set_ordering_index
- (of-object "AppIndicator")
-- (c-name "app_indicator_set_icon")
-- (return-type "none")
-+ (c-name "app_indicator_set_ordering_index")
- (parameters
-- '("const-gchar*" "icon_name")
-+ '("guint32" "ordering_index")
- )
- )
-
-@@ -143,46 +135,66 @@
- (return-type "AppIndicatorStatus")
- )
-
--(define-method get_label
-+(define-method get_icon
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_label")
-+ (c-name "app_indicator_get_icon")
- (return-type "const-gchar*")
- )
-
--(define-method get_label_guide
-+(define-method get_icon_desc
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_label_guide")
-+ (c-name "app_indicator_get_icon_desc")
- (return-type "const-gchar*")
- )
-
--(define-method get_accessible_desc
-+(define-method get_icon_theme_path
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_accessible_desc")
-+ (c-name "app_indicator_get_icon_theme_path")
- (return-type "const-gchar*")
- )
-
--(define-method get_ordering_index
-+(define-method get_attention_icon
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_ordering_index")
-- (return-type "guint32")
-+ (c-name "app_indicator_get_attention_icon")
-+ (return-type "const-gchar*")
- )
-
--(define-method get_icon
-+(define-method get_attention_icon_desc
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_icon")
-+ (c-name "app_indicator_get_attention_icon_desc")
- (return-type "const-gchar*")
- )
-
--(define-method get_icon_theme_path
-+(define-method get_menu
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_icon_theme_path")
-+ (c-name "app_indicator_get_menu")
-+ (return-type "GtkMenu*")
-+)
-+
-+(define-method get_label
-+ (of-object "AppIndicator")
-+ (c-name "app_indicator_get_label")
- (return-type "const-gchar*")
- )
-
--(define-method get_attention_icon
-+(define-method get_label_guide
- (of-object "AppIndicator")
-- (c-name "app_indicator_get_attention_icon")
-+ (c-name "app_indicator_get_label_guide")
- (return-type "const-gchar*")
- )
-
-+(define-method get_ordering_index
-+ (of-object "AppIndicator")
-+ (c-name "app_indicator_get_ordering_index")
-+ (return-type "guint32")
-+)
-
-+(define-method build_menu_from_desktop
-+ (of-object "AppIndicator")
-+ (c-name "app_indicator_build_menu_from_desktop")
-+ (return-type "none")
-+ (parameters
-+ '("const-gchar*" "desktop_file")
-+ '("const-gchar*" "desktop_profile")
-+ )
-+)