aboutsummaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-01-27 22:23:52 -0500
committerKen VanDine <ken.vandine@canonical.com>2011-01-27 22:23:52 -0500
commit93d52e4976dc0df8929afa404cab58889a46d723 (patch)
treeb039f60c53cc7b7b2d53b2c8612e7228afd38a51 /docs/reference/Makefile.am
parentbe00d0092e640dcdb0c5a64f9a8a20178245b716 (diff)
parent19c543fd42571ef3e011db21a6d93e93d7da4483 (diff)
downloadlibayatana-appindicator-93d52e4976dc0df8929afa404cab58889a46d723.tar.gz
libayatana-appindicator-93d52e4976dc0df8929afa404cab58889a46d723.tar.bz2
libayatana-appindicator-93d52e4976dc0df8929afa404cab58889a46d723.zip
Import upstream version 0.2.92
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index b6b0289..ae23e0b 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -9,7 +9,12 @@ AUTOMAKE_OPTIONS = 1.6
# of using the various options.
# The name of the module, e.g. 'glib'.
+if USE_GTK3
+DOC_MODULE=libappindicator3
+else
DOC_MODULE=libappindicator
+endif
+
# Uncomment for versioned docs and specify the version of the module, e.g. '2'.
#DOC_MODULE_VERSION=2
@@ -91,7 +96,7 @@ expand_content_files=
# e.g. GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_srcdir)/src -I$(top_srcdir)/src $(LIBRARY_CFLAGS)
-GTKDOC_LIBS=$(top_builddir)/src/libappindicator.la $(LIBRARY_LIBS)
+GTKDOC_LIBS=$(top_builddir)/src/$(DOC_MODULE).la $(LIBRARY_LIBS)
# This includes the standard gtk-doc make rules, copied by gtkdocize.
include $(top_srcdir)/gtk-doc.local.make