aboutsummaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-01-27 22:34:15 -0500
committerKen VanDine <ken.vandine@canonical.com>2011-01-27 22:34:15 -0500
commitb7ad7ae08ee02fdd8464141b84baa4225daedb28 (patch)
tree502b41d38a508fae407d40bd551c1da8888f5fb2 /docs/reference/Makefile.am
parent62f943d3f3892a59585eba750290757c5c84c81d (diff)
parent93d52e4976dc0df8929afa404cab58889a46d723 (diff)
downloadlibayatana-appindicator-b7ad7ae08ee02fdd8464141b84baa4225daedb28.tar.gz
libayatana-appindicator-b7ad7ae08ee02fdd8464141b84baa4225daedb28.tar.bz2
libayatana-appindicator-b7ad7ae08ee02fdd8464141b84baa4225daedb28.zip
releasing version 0.2.92-0ubuntu10.2.92-0ubuntu1
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index b6b0289..ae23e0b 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -9,7 +9,12 @@ AUTOMAKE_OPTIONS = 1.6
# of using the various options.
# The name of the module, e.g. 'glib'.
+if USE_GTK3
+DOC_MODULE=libappindicator3
+else
DOC_MODULE=libappindicator
+endif
+
# Uncomment for versioned docs and specify the version of the module, e.g. '2'.
#DOC_MODULE_VERSION=2
@@ -91,7 +96,7 @@ expand_content_files=
# e.g. GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_srcdir)/src -I$(top_srcdir)/src $(LIBRARY_CFLAGS)
-GTKDOC_LIBS=$(top_builddir)/src/libappindicator.la $(LIBRARY_LIBS)
+GTKDOC_LIBS=$(top_builddir)/src/$(DOC_MODULE).la $(LIBRARY_LIBS)
# This includes the standard gtk-doc make rules, copied by gtkdocize.
include $(top_srcdir)/gtk-doc.local.make