aboutsummaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-27 08:56:41 -0600
committerTed Gould <ted@gould.cx>2011-01-27 08:56:41 -0600
commit27ae7e26eec862442189eaf94ab2f559d8d28bb5 (patch)
treedaaf0a7f70b7b7921d925aa31bdf450c3b9b8d4c /example/Makefile.am
parent83b9ba8658f3bb4593a32c61eade547ac7bfe965 (diff)
parentceb50bdad13b935da467d6913fa428fd9c8b1dda (diff)
downloadlibayatana-appindicator-27ae7e26eec862442189eaf94ab2f559d8d28bb5.tar.gz
libayatana-appindicator-27ae7e26eec862442189eaf94ab2f559d8d28bb5.tar.bz2
libayatana-appindicator-27ae7e26eec862442189eaf94ab2f559d8d28bb5.zip
* Upstream Merge
* Fixes to build system to build with GTK3 * Use the dbusmenu parser
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index e23e08d..0900baf 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,3 +1,9 @@
+if USE_GTK3
+VER=3
+else
+VER=
+endif
+
check_PROGRAMS = \
simple-client
@@ -17,7 +23,7 @@ simple_client_CFLAGS = \
simple_client_LDADD = \
$(LIBRARY_LIBS) \
- $(top_builddir)/src/libappindicator.la
+ $(top_builddir)/src/libappindicator$(VER).la
EXTRA_DIST = \
simple-client-test-icon.png