aboutsummaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-02-10 14:57:31 -0600
committerTed Gould <ted@gould.cx>2011-02-10 14:57:31 -0600
commita9814d5d7acde62dd8f5cf3424f795bb4c977dd1 (patch)
tree11f2e90896af12c6718eb4b408347bb22b643672 /example/Makefile.am
parent6def775bc45fdcf7ce59ccd08dd89c751b5cf3d3 (diff)
parent18d89929cb035b798916e10a6aa253fd5bcf4e7d (diff)
downloadlibayatana-appindicator-a9814d5d7acde62dd8f5cf3424f795bb4c977dd1.tar.gz
libayatana-appindicator-a9814d5d7acde62dd8f5cf3424f795bb4c977dd1.tar.bz2
libayatana-appindicator-a9814d5d7acde62dd8f5cf3424f795bb4c977dd1.zip
New upstream release.
∘ Fix Vala bindings ∘ Add support for scroll events
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 0900baf..606317c 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -4,9 +4,11 @@ else
VER=
endif
+CLEANFILES =
check_PROGRAMS = \
- simple-client
+ simple-client \
+ simple-client-vala
#########################################
## simple-client
@@ -27,3 +29,28 @@ simple_client_LDADD = \
EXTRA_DIST = \
simple-client-test-icon.png
+
+#########################################
+## simple-client-vala
+#########################################
+if HAVE_VALAC
+
+VALAFLAGS = \
+ --pkg appindicator$(VER)-0.1 \
+ --vapidir=$(top_builddir)/bindings/vala
+
+BUILT_SOURCES = simple-client-vala.c
+simple-client-vala.c: $(srcdir)/simple-client-vala.vala
+ $(VALAC) $(VALAFLAGS) -C $< -o $@
+ $(SED) -i "s|#include\s*<\s*libappindicator/app-indicator.h\s*>||g" $@
+
+simple_client_vala_SOURCES = simple-client-vala.c
+simple_client_vala_CFLAGS = \
+ $(simple_client_CFLAGS) \
+ -include $(top_srcdir)/src/app-indicator.h
+
+simple_client_vala_LDADD = $(simple_client_LDADD)
+
+CLEANFILES += *.stamp *-vala.c
+
+endif