aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-08-12 09:31:40 -0500
committerTed Gould <ted@gould.cx>2010-08-12 09:31:40 -0500
commit374ce0d9c90fb80b0fdf916a3fe170b050abb0fc (patch)
tree36d90bcb75ef8d9c4a7a07c25d16b5b30339c175 /src/Makefile.am
parent15f7dee1de99f6bceb4c714ef1a8ff2e7b0add09 (diff)
parent6769e30333d906eb69789aff69d58851fe08fc00 (diff)
downloadlibayatana-appindicator-374ce0d9c90fb80b0fdf916a3fe170b050abb0fc.tar.gz
libayatana-appindicator-374ce0d9c90fb80b0fdf916a3fe170b050abb0fc.tar.bz2
libayatana-appindicator-374ce0d9c90fb80b0fdf916a3fe170b050abb0fc.zip
* Upstream Merge
* Add in ordering IDs
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0e84749..1c4e7ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,17 +44,20 @@ indicator_application_service_SOURCES = \
application-service.c \
application-service-appstore.h \
application-service-appstore.c \
- application-service-lru-file.h \
- application-service-lru-file.c \
application-service-marshal.c \
application-service-watcher.h \
application-service-watcher.c \
app-indicator-enum-types.c \
- dbus-shared.h
+ dbus-shared.h \
+ generate-id.h \
+ generate-id.c
+
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ -DDATADIR="\"$(pkgdatadir)\"" \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
+
indicator_application_service_LDADD = \
$(INDICATOR_LIBS) \
libappindicator.la
@@ -95,7 +98,9 @@ libappindicator_la_SOURCES = \
$(libappindicator_headers) \
app-indicator-enum-types.c \
app-indicator.c \
- application-service-marshal.c
+ application-service-marshal.c \
+ generate-id.h \
+ generate-id.c
libappindicator_la_LDFLAGS = \
-version-info 1:0:0 \