aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-13 15:48:42 -0500
committerTed Gould <ted@canonical.com>2009-10-13 15:48:42 -0500
commite265e46176c6c8633849b3a5d65b7f86bda47318 (patch)
tree3d3f461747a9626556cc6b2e11d280f7f1fa3c77 /src/Makefile.am
parent140fda5adff2a21f9c158c941456d9e1f5765832 (diff)
parentfb328a435358e26c1f2779e2bf07ddb05b60e93e (diff)
downloadlibayatana-appindicator-e265e46176c6c8633849b3a5d65b7f86bda47318.tar.gz
libayatana-appindicator-e265e46176c6c8633849b3a5d65b7f86bda47318.tar.bz2
libayatana-appindicator-e265e46176c6c8633849b3a5d65b7f86bda47318.zip
A basical build system and basic files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..63f0c64
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,31 @@
+
+libexec_PROGRAMS = indicator-custom-service
+
+##################################
+# Indicator
+##################################
+
+customlibdir = $(INDICATORDIR)
+customlib_LTLIBRARIES = libcustom.la
+libcustom_la_SOURCES = \
+ indicator-custom.c
+libcustom_la_CFLAGS = $(INDICATOR_CFLAGS) \
+ -Wall \
+ -Wl,-Bsymbolic-functions \
+ -Wl,-z,defs \
+ -Wl,--as-needed \
+ -Werror
+libcustom_la_LIBADD = $(INDICATOR_LIBS)
+libcustom_la_LDFLAGS = -module -avoid-version
+
+##################################
+# Service
+##################################
+
+indicator_custom_service_SOURCES = \
+ custom-service.c
+indicator_custom_service_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror
+indicator_custom_service_LDADD = \
+ $(INDICATOR_LIBS)