aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-12-19 17:34:38 +0000
committerTarmac <Unknown>2013-12-19 17:34:38 +0000
commit25762ad8307f81c09307419d48fdfb94bdc396ae (patch)
treee4b3c053e75d0df5c375e428499ac5e38de92b34 /tests/Makefile.am
parent65bc7f80becdd2f2e01be4e14a7d2d960615cdb9 (diff)
parent52c50b3f9b571f44dc1f255365dc5c90ab2c6730 (diff)
downloadlibayatana-appindicator-25762ad8307f81c09307419d48fdfb94bdc396ae.tar.gz
libayatana-appindicator-25762ad8307f81c09307419d48fdfb94bdc396ae.tar.bz2
libayatana-appindicator-25762ad8307f81c09307419d48fdfb94bdc396ae.zip
Fix build failures on trusty. Fixes: https://bugs.launchpad.net/bugs/1262655.
Approved by PS Jenkins bot, Charles Kerr.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index aed7d7f..570cfe5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -32,7 +32,7 @@ test_libappindicator_SOURCES = \
test_libappindicator_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
-DSRCDIR="\"$(srcdir)\"" \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_LDADD = \
@@ -49,7 +49,7 @@ test_libappindicator_dbus_client_SOURCES = \
test_libappindicator_dbus_client_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_dbus_client_LDADD = \
@@ -66,7 +66,7 @@ test_libappindicator_dbus_server_SOURCES = \
test_libappindicator_dbus_server_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_dbus_server_LDADD = \
@@ -83,7 +83,7 @@ test_libappindicator_status_client_SOURCES = \
test_libappindicator_status_client_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_status_client_LDADD = \
@@ -100,7 +100,7 @@ test_libappindicator_status_server_SOURCES = \
test_libappindicator_status_server_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_status_server_LDADD = \
@@ -116,7 +116,7 @@ test_libappindicator_fallback_watcher_SOURCES = \
test_libappindicator_fallback_watcher_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_fallback_watcher_LDADD = \
@@ -128,7 +128,7 @@ test_libappindicator_fallback_item_SOURCES = \
test_libappindicator_fallback_item_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_libappindicator_fallback_item_LDADD = \
@@ -198,7 +198,7 @@ test_simple_app_SOURCES = \
test_simple_app_CFLAGS = \
$(TESTDEPS_CFLAGS) $(LIBRARY_CFLAGS) \
- -Wall -Werror \
+ -Wall -Werror -Wno-error=deprecated-declarations \
-I$(top_srcdir)/src
test_simple_app_LDADD = \