aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 6 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index c4f16bc..f730a3f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,10 +17,6 @@ CFLAGS += -fPIC
%:
dh $@ --with autoreconf,python2,cli,gir
-# Note: No cli here so that the pbuilder stuff works
-clean:
- dh_clean
-
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
@@ -72,14 +68,17 @@ override_dh_install:
override_dh_auto_test: $(FLAVORS:%=dotest-%)
dotest-%:
- #dh_auto_test --builddirectory=build/$*
+ dh_auto_test --builddirectory=build/$* --
+
dotest-gtk2: $(PY_VERSIONS:%=dotestgtk2-%)
# GTK2 flavor test was run on a per-python-version basis.
dotestgtk2-%:
- #PYTHON=`which $*` \
- # dh_auto_test --builddirectory=build/gtk2
+ ps -ef
+ env
+ PYTHON=`which $*` \
+ dh_auto_test --builddirectory=build/gtk2 --
override_dh_auto_clean:
dh_auto_clean