aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-01-27 10:04:34 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-01-27 10:04:34 +0100
commitabbda6214d6030de108f30f7b9e9acc91c67954f (patch)
tree971ff2e94d6f43081e041541c02856b74bc2a322 /CMakeLists.txt
parent9ee70e789ad3dc4ba4003d0ae59bce72b36378f3 (diff)
parent82f20e9bee0cd782311a1dd14dc373733f8066b1 (diff)
downloadlibayatana-common-abbda6214d6030de108f30f7b9e9acc91c67954f.tar.gz
libayatana-common-abbda6214d6030de108f30f7b9e9acc91c67954f.tar.bz2
libayatana-common-abbda6214d6030de108f30f7b9e9acc91c67954f.zip
Merge branch 'tari01-pr/cleanup-compile-flags'
Attributes GH PR #55: https://github.com/AyatanaIndicators/libayatana-common/pull/55
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47cf270..4fdda11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,8 +27,13 @@ else()
endif()
if(ENABLE_WERROR)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ add_definitions("-Werror")
+endif()
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_definitions("-Weverything")
+else()
+ add_definitions("-Wall")
endif()
# GNU standard installation directories
@@ -61,8 +66,6 @@ include_directories (${DEPS_INCLUDE_DIRS})
find_package (GObjectIntrospection QUIET)
find_package (Vala QUIET)
-set(CC_WARNING_ARGS " -Wall -pedantic -Wextra -Wno-missing-field-initializers")
-
add_subdirectory(src)
add_subdirectory(data)
add_subdirectory(po)