aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-14 21:50:12 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-14 21:50:12 +0100
commit2d445b6517890a826e10ec2f29c32728c395fd2a (patch)
tree93af2806e379cb0805813b56f40f18c9003519e5 /src/CMakeLists.txt
parentf61623a582aaa31ad02d72c5aebab6af3408fc38 (diff)
parent7c4c023ace4cd1b94c4fb0b6d8a8c060f10df752 (diff)
downloadlibayatana-common-2d445b6517890a826e10ec2f29c32728c395fd2a.tar.gz
libayatana-common-2d445b6517890a826e10ec2f29c32728c395fd2a.tar.bz2
libayatana-common-2d445b6517890a826e10ec2f29c32728c395fd2a.zip
Merge branch 'tari01-pr/add-enable-lomiri-features-switch'
Attributes GH PR #52: https://github.com/AyatanaIndicators/libayatana-common/pull/52
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3e4d529..7ca0f5f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,12 +4,11 @@ add_library(ayatana-common SHARED
)
target_link_libraries(ayatana-common
- ${GLIB_LIBRARIES}
- ${URLDISPATCHER_LIBRARIES}
+ ${DEPS_LIBRARIES}
)
-if(URLDISPATCHER_FOUND)
- add_definitions( -DHAS_URLDISPATCHER )
+if(ENABLE_LOMIRI_FEATURES)
+ add_definitions( -DLOMIRI_FEATURES_ENABLED )
endif()
set(PUBLIC_HEADERS