aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-14 21:50:12 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-14 21:50:12 +0100
commit2d445b6517890a826e10ec2f29c32728c395fd2a (patch)
tree93af2806e379cb0805813b56f40f18c9003519e5 /tests/CMakeLists.txt
parentf61623a582aaa31ad02d72c5aebab6af3408fc38 (diff)
parent7c4c023ace4cd1b94c4fb0b6d8a8c060f10df752 (diff)
downloadlibayatana-common-2d445b6517890a826e10ec2f29c32728c395fd2a.tar.gz
libayatana-common-2d445b6517890a826e10ec2f29c32728c395fd2a.tar.bz2
libayatana-common-2d445b6517890a826e10ec2f29c32728c395fd2a.zip
Merge branch 'tari01-pr/add-enable-lomiri-features-switch'
Attributes GH PR #52: https://github.com/AyatanaIndicators/libayatana-common/pull/52
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt15
1 files changed, 7 insertions, 8 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 002e4db..7758e59 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -25,8 +25,7 @@ target_include_directories(tst_utils PUBLIC "${CMAKE_SOURCE_DIR}/src")
target_link_libraries(tst_utils
ayatana-common
- ${GLIB_LIBRARIES}
- ${URL_DISPATCHER_LIBRARIES}
+ ${DEPS_LIBRARIES}
${GTEST_LIBRARIES}
${GTEST_BOTH_LIBRARIES}
${GMOCK_LIBRARIES}
@@ -58,11 +57,11 @@ add_custom_command(
if (VALA_COMPILER)
- add_executable("tst_utils_vala" "${CMAKE_CURRENT_BINARY_DIR}/tst_utils.c")
- target_include_directories("tst_utils_vala" PUBLIC "${GLIB_INCLUDE_DIRS};${CMAKE_BINARY_DIR}/src")
- target_link_libraries("tst_utils_vala" "${GLIB_LIBRARIES} -layatana-common -L${CMAKE_BINARY_DIR}/src")
- target_link_directories("tst_utils_vala" PUBLIC "${CMAKE_BINARY_DIR}/src")
- add_dependencies("tst_utils_vala" "src")
+ add_executable("tst_utils_vala" "${CMAKE_CURRENT_BINARY_DIR}/tst_utils.c")
+ target_include_directories("tst_utils_vala" PUBLIC "${DEPS_INCLUDE_DIRS};${CMAKE_BINARY_DIR}/src")
+ target_link_libraries("tst_utils_vala" "${DEPS_LIBRARIES} -layatana-common -L${CMAKE_BINARY_DIR}/src")
+ target_link_directories("tst_utils_vala" PUBLIC "${CMAKE_BINARY_DIR}/src")
+ add_dependencies("tst_utils_vala" "src")
- add_test(NAME "TstUtilsVala" COMMAND "${CMAKE_CURRENT_BINARY_DIR}/tst_utils_vala" "${CMAKE_CURRENT_BINARY_DIR}")
+ add_test(NAME "TstUtilsVala" COMMAND "${CMAKE_CURRENT_BINARY_DIR}/tst_utils_vala" "${CMAKE_CURRENT_BINARY_DIR}")
endif()