aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5be74c7..7430e86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,14 @@ if (ENABLE_TESTS)
include(CTest)
enable_testing()
add_subdirectory(tests)
+ if (ENABLE_COVERAGE)
+ find_package(CoverageReport)
+ ENABLE_COVERAGE_REPORT(
+ TARGETS "ayatana-common"
+ TESTS "tst_utils"
+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+ )
+ endif()
endif()
# Display config info