aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-21 15:53:41 -0500
committerTed Gould <ted@gould.cx>2010-09-21 15:53:41 -0500
commitb91aaa92453fbab73397019070d86c0a9b6fa7ce (patch)
tree202964318d3dbf46edef77a10b7029c3e0752a17 /Makefile.am
parentb675da761008a640e02b90aa6b99e345875bd00d (diff)
parent558a37d1ad6479d912c8af6f209f7ba3b7cdc823 (diff)
downloadlibayatana-indicator-b91aaa92453fbab73397019070d86c0a9b6fa7ce.tar.gz
libayatana-indicator-b91aaa92453fbab73397019070d86c0a9b6fa7ce.tar.bz2
libayatana-indicator-b91aaa92453fbab73397019070d86c0a9b6fa7ce.zip
Import upstream version 0.3.14
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8894e24..f290d63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,3 +7,29 @@ SUBDIRS = \
DISTCLEANFILES = \
libindicator-*.tar.gz
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi
+