aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2008-10-29 17:16:49 -0500
committerTed Gould <ted@canonical.com>2008-10-29 17:16:49 -0500
commit9c2e7b6066f217e3879067a6f2b368de98c5fd8e (patch)
tree753009d866ef2bd1d9bd7bdf2bdedf6bf39b4ef2 /configure.ac
downloadlibayatana-indicator-9c2e7b6066f217e3879067a6f2b368de98c5fd8e.tar.gz
libayatana-indicator-9c2e7b6066f217e3879067a6f2b368de98c5fd8e.tar.bz2
libayatana-indicator-9c2e7b6066f217e3879067a6f2b368de98c5fd8e.zip
Basic build system, not quite working though
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..74fbab9
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,50 @@
+
+AC_INIT(src/applet-main.c)
+
+AC_PREREQ(2.53)
+
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(indicator-applet, 0.1)
+
+AM_MAINTAINER_MODE
+
+IT_PROG_INTLTOOL([0.35.0])
+AC_ISC_POSIX
+AC_PROG_CC
+AC_STDC_HEADERS
+AC_PROG_LIBTOOL
+
+AC_SUBST(VERSION)
+AC_CONFIG_MACRO_DIR([m4])
+
+###########################
+# Dependencies
+###########################
+
+GTK_REQUIRED_VERSION=2.12
+PANEL_REQUIRED_VERSION=2.0.0
+
+PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION)
+AC_SUBST(APPLET_CFLAGS)
+AC_SUBST(APPLET_LIBS)
+
+###########################
+# Files
+###########################
+
+AC_OUTPUT([
+Makefile
+src/Makefile
+])
+
+###########################
+# Results
+###########################
+
+AC_MSG_NOTICE([
+
+Indicator Applet Configuration:
+
+ Prefix: $prefix
+])