aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-01-16 16:21:09 -0600
committerTed Gould <ted@canonical.com>2009-01-16 16:21:09 -0600
commitac140d5000a6f6698f5b7d690ba48c877472c054 (patch)
tree464ee8f3babdc7793e4e4f3339d677165b8e5f84 /configure.ac
parente83283e29941c9f6e4a0b20cc179c846edf7dc47 (diff)
downloadlibayatana-indicator-ac140d5000a6f6698f5b7d690ba48c877472c054.tar.gz
libayatana-indicator-ac140d5000a6f6698f5b7d690ba48c877472c054.tar.bz2
libayatana-indicator-ac140d5000a6f6698f5b7d690ba48c877472c054.zip
Bringing GObject Introspection into the build and making it so that
it gets installed with the library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc408e3..3ec1ed7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,22 @@ PKG_CHECK_MODULES(LIBINDICATE, glib-2.0 >= $GLIB_REQUIRED_VERSION
AC_SUBST(LIBINDICATE_CFLAGS)
AC_SUBST(LIBINDICATE_LIBS)
+# GObject Introspection
+
+PKG_CHECK_MODULES(GOBJECT_INTROSPECTION, [gobject-introspection-1.0 >= 0.6])
+
+G_IR_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
+AC_SUBST(G_IR_SCANNER)
+G_IR_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
+AC_SUBST(G_IR_COMPILER)
+G_IR_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
+AC_SUBST(G_IR_GENERATE)
+
+GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
+AC_SUBST(GIRDIR)
+TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+AC_SUBST(TYPELIBDIR)
+
###########################
# Internationalization
###########################