aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-02 16:31:03 -0600
committerTed Gould <ted@canonical.com>2009-11-02 16:31:03 -0600
commit8e4486c2cee166ffaeae2baa4fe727e62f1babf5 (patch)
tree8e4b294239dce0e6620dace758d704bc97d5a614 /configure.ac
parentd9dc7707402a979e3d23d5afc2fcd18ce57f0b54 (diff)
parent5ccc73bea6b75cc3a027f831bb60bfcf43714deb (diff)
downloadlibayatana-indicator-8e4486c2cee166ffaeae2baa4fe727e62f1babf5.tar.gz
libayatana-indicator-8e4486c2cee166ffaeae2baa4fe727e62f1babf5.tar.bz2
libayatana-indicator-8e4486c2cee166ffaeae2baa4fe727e62f1babf5.zip
Adding in service management code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 090e281..d2e18fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,19 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
##############################
+# Dependencies
+##############################
+
+GTK_REQUIRED_VERSION=2.18
+DBUS_REQUIRED_VERSION=0.76
+
+PKG_CHECK_MODULES(LIBINDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
+
+AC_SUBST(LIBINDICATOR_CFLAGS)
+AC_SUBST(LIBINDICATOR_LIBS)
+
+##############################
# Custom Junk
##############################
@@ -73,6 +86,8 @@ AC_OUTPUT([
Makefile
libindicator/Makefile
libindicator/indicator.pc
+tests/Makefile
+tools/Makefile
])
###########################