aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-03 11:16:20 -0600
committerTed Gould <ted@canonical.com>2009-11-03 11:16:20 -0600
commit1021a835cfe8adaabb367f67585f701cd0b5f4d5 (patch)
tree758ba7cb235c3adf09bb45b226a5bc015a3379dc /configure.ac
parentb5f41d1c0ca30f1cf7379e754d906681ccfbe9e1 (diff)
parentb3fc7791fdf7bea9787555b63c33e0b1f67390c4 (diff)
downloadlibayatana-indicator-1021a835cfe8adaabb367f67585f701cd0b5f4d5.tar.gz
libayatana-indicator-1021a835cfe8adaabb367f67585f701cd0b5f4d5.tar.bz2
libayatana-indicator-1021a835cfe8adaabb367f67585f701cd0b5f4d5.zip
We need atleast the loader branch as that's what we want to change.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 090e281..d2e18fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,19 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
##############################
+# Dependencies
+##############################
+
+GTK_REQUIRED_VERSION=2.18
+DBUS_REQUIRED_VERSION=0.76
+
+PKG_CHECK_MODULES(LIBINDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
+
+AC_SUBST(LIBINDICATOR_CFLAGS)
+AC_SUBST(LIBINDICATOR_LIBS)
+
+##############################
# Custom Junk
##############################
@@ -73,6 +86,8 @@ AC_OUTPUT([
Makefile
libindicator/Makefile
libindicator/indicator.pc
+tests/Makefile
+tools/Makefile
])
###########################