aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-06 16:32:23 -0400
committerTed Gould <ted@canonical.com>2009-10-06 16:32:23 -0400
commit24d025363c4a708c61acee26456a42a0b9a4b609 (patch)
tree272caca0c758d96dd6efc6a33f4ba1ba6bddbb69 /configure.ac
parent1f822bf64b8891dab03937060dd47b8003bb8ab5 (diff)
downloadlibayatana-indicator-24d025363c4a708c61acee26456a42a0b9a4b609.tar.gz
libayatana-indicator-24d025363c4a708c61acee26456a42a0b9a4b609.tar.bz2
libayatana-indicator-24d025363c4a708c61acee26456a42a0b9a4b609.zip
Adding some pkg-config love to get things compiling all nice like.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70ef98b..fc7fcab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,19 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
##############################
+# Dependencies
+##############################
+
+GLIB_REQUIRED_VERSION=2.18
+DBUS_REQUIRED_VERSION=0.76
+
+PKG_CHECK_MODULES(LIBINDICATOR, glib-2.0 >= $GLIB_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
+
+AC_SUBST(LIBINDICATOR_CFLAGS)
+AC_SUBST(LIBINDICATOR_LIBS)
+
+##############################
# Custom Junk
##############################