aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-28 16:46:25 -0500
committerTed Gould <ted@canonical.com>2009-10-28 16:46:25 -0500
commit0220cc7a435f3f03761697afd316ac1b86a10211 (patch)
treed612bfedf1888385c5e5e6a5c7d0f3c530f19dcb /configure.ac
parentb5f41d1c0ca30f1cf7379e754d906681ccfbe9e1 (diff)
parentb98a4811a0b03335da1fad3d0e0bce08bdad2a00 (diff)
downloadlibayatana-indicator-0220cc7a435f3f03761697afd316ac1b86a10211.tar.gz
libayatana-indicator-0220cc7a435f3f03761697afd316ac1b86a10211.tar.bz2
libayatana-indicator-0220cc7a435f3f03761697afd316ac1b86a10211.zip
Grabbing the loader branch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 090e281..d2e18fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,19 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
##############################
+# Dependencies
+##############################
+
+GTK_REQUIRED_VERSION=2.18
+DBUS_REQUIRED_VERSION=0.76
+
+PKG_CHECK_MODULES(LIBINDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
+
+AC_SUBST(LIBINDICATOR_CFLAGS)
+AC_SUBST(LIBINDICATOR_LIBS)
+
+##############################
# Custom Junk
##############################
@@ -73,6 +86,8 @@ AC_OUTPUT([
Makefile
libindicator/Makefile
libindicator/indicator.pc
+tests/Makefile
+tools/Makefile
])
###########################